<!doctype html>
<html lang="en-GB">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
    <meta name="theme-color" content="#d60b52">

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO Premium plugin v16.7 (Yoast SEO v16.7) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>National Television Awards: Viewers praise host Joel Dommett and call for him to be permanent presenter</title>
	<meta name="description" content="National Television Awards took place last night and viewers praised host Joel Dommett and called for him to be permanent presenter." />
	<link rel="canonical" href="https://www.entertainmentdaily.co.uk/tv/national-television-awards-joel-dommett-praised-by-viewers-but-they-all-have-one-question-about-his-appearance/" />
	<meta property="og:locale" content="en_GB" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="National Television Awards: Joel Dommett praised by viewers but they all have one question about his appearance" />
	<meta property="og:description" content="National Television Awards took place last night and viewers praised host Joel Dommett and called for him to be permanent presenter." />
	<meta property="og:url" content="https://www.entertainmentdaily.co.uk/tv/national-television-awards-joel-dommett-praised-by-viewers-but-they-all-have-one-question-about-his-appearance/" />
	<meta property="og:site_name" content="Entertainment Daily" />
	<meta property="article:publisher" content="https://www.facebook.com/entertainmentdailyfix/" />
	<meta property="article:published_time" content="2021-09-10T12:06:16+00:00" />
	<meta property="og:image" content="https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27.jpg" />
	<meta property="og:image:width" content="1500" />
	<meta property="og:image:height" content="784" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@EntDailyUK" />
	<meta name="twitter:site" content="@EntDailyUK" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Paul Hirons" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="3 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<meta property="og:video" content="https://www.youtube.com/embed/OL-ZgvT--Vo" />
	<meta property="og:video:type" content="text/html" />
	<meta property="og:video:duration" content="477" />
	<meta property="og:video:width" content="480" />
	<meta property="og:video:height" content="270" />
	<meta property="ya:ovs:adult" content="false" />
	<meta property="ya:ovs:upload_date" content="2021-09-10T12:06:16+00:00" />
	<meta property="ya:ovs:allow_embed" content="true" />
	<!-- / Yoast SEO Premium plugin. -->


<link rel='stylesheet' id='ed-style-css'  href='https://www.entertainmentdaily.co.uk/wp-content/themes/ed/style.css?ver=1.0' media='all' />
<link rel="icon" href="https://cdn.entertainmentdaily.com/2021/01/25101916/cropped-logo-512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://cdn.entertainmentdaily.com/2021/01/25101916/cropped-logo-512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://cdn.entertainmentdaily.com/2021/01/25101916/cropped-logo-512-180x180.png" />
<meta name="msapplication-TileImage" content="https://cdn.entertainmentdaily.com/2021/01/25101916/cropped-logo-512-270x270.png" />

    <link href="https://fonts.gstatic.com" rel="preconnect" crossorigin>
    <style id="" media="all">@font-face {
  font-family: 'Montserrat';
  font-style: italic;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/montserrat/v18/JTUQjIg1_i6t8kCHKm459WxRyS7j.ttf) format('truetype');
}
@font-face {
  font-family: 'Montserrat';
  font-style: italic;
  font-weight: 600;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/montserrat/v18/JTUPjIg1_i6t8kCHKm459WxZFgrz_PZ1.ttf) format('truetype');
}
@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/montserrat/v18/JTUSjIg1_i6t8kCHKm459Wlhzg.ttf) format('truetype');
}
@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 500;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/montserrat/v18/JTURjIg1_i6t8kCHKm45_ZpC3gnD-w.ttf) format('truetype');
}
@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 600;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/montserrat/v18/JTURjIg1_i6t8kCHKm45_bZF3gnD-w.ttf) format('truetype');
}
</style>

    <script>dataLayer = [{'gtm.start': new Date().getTime(), event: 'gtm.js'}]; ED = {q:[]}</script>
    <script src="https://www.googletagmanager.com/gtm.js?id=GTM-NV5NXDR" async></script>

    <script>!function(){var n=document.createElement("script"),e=document.getElementsByTagName("script")[0],t="https://quantcast.mgr.consensu.org".concat("/choice/","EDqRupKXQvznL","/","entertainmentdaily.co.uk","/choice.js"),a=0;function o(){var n,o="__tcfapiLocator",a=[],i=window;for(;i;){try{if(i.frames[o]){n=i;break}}catch(n){}if(i===window.top)break;i=i.parent}n||(!function n(){var e,t=i.document,a=!!i.frames[o];return a||(t.body?((e=t.createElement("iframe")).style.cssText="display:none",e.name=o,t.body.appendChild(e)):setTimeout(n,5)),!a}(),i.__tcfapi=function(){var n,e,t=arguments;if(!t.length)return a;"setGdprApplies"===t[0]?3<t.length&&2===t[2]&&"boolean"==typeof t[3]&&(n=t[3],"function"==typeof t[2]&&t[2]("set",!0)):"ping"===t[0]?(e={gdprApplies:n,cmpLoaded:!1,cmpStatus:"stub"},"function"==typeof t[2]&&t[2](e)):a.push(t)},i.addEventListener("message",function(a){var o="string"==typeof a.data,n={};try{n=o?JSON.parse(a.data):a.data}catch(n){}var i=n.__tcfapiCall;i&&window.__tcfapi(i.command,i.version,function(n,e){var t={__tcfapiReturn:{returnValue:n,success:e,callId:i.callId}};o&&(t=JSON.stringify(t)),a.source.postMessage(t,"*")},i.parameter)},!1))}n.async=!0,n.type="text/javascript",n.src=t,e.parentNode.insertBefore(n,e),"undefined"!=typeof module?module.exports=o:o();var i,s=function(){var n=arguments;typeof window.__uspapi!==s&&setTimeout(function(){void 0!==window.__uspapi&&window.__uspapi.apply(window.__uspapi,n)},500)};void 0===window.__uspapi&&(window.__uspapi=s,i=setInterval(function(){a++,window.__uspapi===s&&a<3?console.warn("USP is not accessible"):clearInterval(i)},6e3))}(),document.addEventListener("click",function(n){try{-1<n.target.className.indexOf("js-show-cmp")&&(n.preventDefault(),window.__tcfapi("displayConsentUi",2,function(){}))}catch(n){}},{capture:!0}),function(){(0,window.__tcfapi)("addEventListener",2,function(t,n){n&&("tcloaded"!==t.eventStatus&&"useractioncomplete"!==t.eventStatus||window.__tcfapi("getNonIABVendorConsents",2,function(n,e){e&&(window.dataLayer=window.dataLayer||[],window.dataLayer.push({event:"__cmpConsents",__cmpConsents:a(t,n)}))}))});function t(e){return","+Object.keys(e).filter(function(n){return e[n]}).join(",")+","}var a=function(n,e){return{iabVendorConsentIds:t(n.vendor.consents),nonIABVendorConsentIds:t(e.nonIabVendorConsents)}}}();;document.addEventListener("click",function(e){var t=e.target;t&&"nav-toggle"===t.id&&(t.setAttribute("aria-expanded","false"===t.getAttribute("aria-expanded")?"true":"false"),document.getElementById("nav-menu").classList.toggle("hidden"))});</script>

    <script src="https://www.entertainmentdaily.co.uk/wp-content/themes/ed/js/lazysizes.b80e49.js" async></script>

        <script src="https://www.entertainmentdaily.co.uk/wp-content/themes/ed/js/prebid.071fb6.js" async></script>
    <script src="https://www.entertainmentdaily.co.uk/wp-content/themes/ed/js/stack.095f17.js" async></script>
    <script src="https://securepubads.g.doubleclick.net/tag/js/gpt.js" async></script>
    
            <script>
            dataLayer.push({"author":"Paul Hirons","category":"TV","slug":"national-television-awards-joel-dommett-praised-by-viewers-but-they-all-have-one-question-about-his-appearance","published_at":"202109101306","page_type":"post"});
            ED.post = {"id":712467,"author":"Paul Hirons","slug":"national-television-awards-joel-dommett-praised-by-viewers-but-they-all-have-one-question-about-his-appearance","tags":["Joel Dommett","National Television Awards","NTAs"],"categories":["TV"]};
        </script>
        <script src="https://www.entertainmentdaily.co.uk/wp-content/themes/ed/js/article.2b347d.js" defer></script>
    
	</head>

<body>


<div style="display:none;visibility:hidden;">
    <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><symbol viewBox="0 0 160 160" id="icon-facebook"><path d="M129.712.096q12.487 0 21.246 8.946 8.76 8.946 8.76 21.06v99.893q0 12.3-8.76 21.06-8.76 8.759-21.246 8.945H110.33V97.94h20.687l2.982-24.042h-23.67V58.429q0-5.777 2.424-8.572 2.422-2.796 9.504-2.982l12.673-.187V25.256q-6.522-.932-18.636-.932-13.978 0-22.55 8.2-8.574 8.2-8.387 23.669v17.705H64.483v24.041h20.874V160H30.005q-12.486 0-21.246-8.946Q0 142.11 0 129.994V30.103q0-12.3 8.76-21.06Q17.518.282 30.004.096h99.707z"/></symbol><symbol viewBox="0 0 186 115" id="icon-logo"><path d="M64.2 50.9H30.1L27.7 68h40.7l-2.6 17.5H4.9L16.7 1.6h60.9l-2.4 17.5H34.5L32.3 35h34.1zm40.5 34.6H72.4L84.1 1.6h32.3c24.4 0 38.7 15.4 38.7 36.5 0 26.5-20.7 47.4-50.4 47.4M102 19.1L95.2 68h10.5c14.9 0 28.4-10.6 28.4-28.1 0-13.7-9.2-20.8-21.5-20.8H102zM166 63c6 0 10.3 4.6 10.3 10.5 0 7.3-6.6 13.1-13.7 13.1-6 0-10.2-4.5-10.2-10.3.1-7.3 6.4-13.3 13.6-13.3m7.6-7.4h-13.1l2.7-53.9H186l-12.4 53.9zM11.1 104.9H5l-.4 3.5h7.2l-.4 2.4h-10l2-13.9h10l-.4 2.5H5.8l-.4 3.2h6.1zm4.1 5.9h-2.8l1.4-9.7h1.7l.2 1.4h.2c.9-1.1 1.8-1.6 3.4-1.6 2.5 0 3.8 1.7 3.4 4.3l-.8 5.7h-2.8l.8-5.4c.2-1.2-.4-2.1-1.7-2.1s-2.1 1-2.3 2l-.7 5.4zm10.1-9.7l.4-3h2.8l-.4 3h2.4l-.3 2.2h-2.4l-.6 4.4c-.1.7.2 1.1.9 1.1.6 0 1.1-.3 1.1-.3l.5 1.9c-.4.3-1.5.8-2.6.8-2.3 0-3-1.4-2.7-3.4l.6-4.5h-1.7l.3-2.2h1.7z"/><path d="M38.5 109.9s-1.3 1.2-3.8 1.2c-2.9 0-4.6-1.9-4.6-4.4 0-3.3 2.4-5.8 5.6-5.8 2.5 0 3.9 1.6 3.9 4.1 0 .8-.2 1.6-.2 1.6h-6.7c-.1 1.7.8 2.4 2.4 2.4 1.5 0 2.6-.8 2.6-.8l.8 1.7zm-5.4-5.1H37c0-1.2-.5-1.9-1.6-1.9s-1.9.6-2.3 1.9m13.2-1.4h-.5c-1.3 0-2.4.9-2.6 2.4l-.7 5h-2.8l1.4-9.7h1.7l.2 1.4h.1c.7-1 1.6-1.4 2.9-1.4h.5l-.2 2.3zm2.9-2.3l.4-3h2.8l-.4 3h2.4l-.3 2.2h-2.4l-.6 4.4c-.1.7.2 1.1.9 1.1.6 0 1.1-.3 1.1-.3l.5 1.9c-.4.3-1.5.8-2.6.8-2.3 0-3-1.4-2.7-3.4l.6-4.5h-1.7l.3-2.2h1.7z"/><path d="M62.4 102.4l.6-1.3h1.8l-1.4 9.7h-1.8l-.3-1.3h-.1s-1 1.6-3.4 1.6c-2.3 0-3.9-1.7-3.9-4.3 0-3.4 2.5-5.9 5.3-5.9 2.4 0 3 1.6 3 1.6h.2zm-2.8.7c-1.5 0-2.7 1.4-2.7 3.2 0 1.4.7 2.4 1.9 2.4 1.6 0 2.8-1.3 2.8-3.3.1-1.4-.7-2.3-2-2.3m6.8-2h2.8l-1.4 9.7H65l1.4-9.7zm.2-2.9c0-1 .9-1.8 1.9-1.8.8 0 1.4.6 1.4 1.4 0 1-.9 1.8-1.9 1.8-.8 0-1.4-.6-1.4-1.4m5.5 12.6h-2.8l1.4-9.7h1.7l.2 1.4h.2c.9-1.1 1.8-1.6 3.4-1.6 2.5 0 3.8 1.7 3.4 4.3l-.8 5.7H76l.8-5.4c.2-1.2-.4-2.1-1.7-2.1s-2.1 1-2.3 2l-.7 5.4zm17.2 0h-2.8l.8-5.5c.2-1.1-.4-2-1.7-2s-2.1.9-2.2 1.9l-.8 5.7h-2.8l1.4-9.7h1.7l.2 1.4h.2c.8-1 1.8-1.6 3.3-1.6 1.6 0 2.7.6 3.2 1.7h.1c.8-1 1.8-1.7 3.4-1.7 2.5 0 3.8 1.7 3.4 4.3l-.8 5.7h-2.8l.8-5.4c.2-1.2-.4-2.1-1.6-2.1-1.3 0-2.1 1-2.2 2l-.8 5.3zm16.5-.9s-1.3 1.2-3.8 1.2c-2.9 0-4.6-1.9-4.6-4.4 0-3.3 2.4-5.8 5.6-5.8 2.5 0 3.9 1.6 3.9 4.1 0 .8-.2 1.6-.2 1.6H100c-.1 1.7.8 2.4 2.4 2.4 1.5 0 2.6-.8 2.6-.8l.8 1.7zm-5.4-5.1h3.9c0-1.2-.5-1.9-1.6-1.9s-1.9.6-2.3 1.9m9.4 6H107l1.4-9.7h1.7l.2 1.4h.2c.9-1.1 1.8-1.6 3.4-1.6 2.5 0 3.8 1.7 3.4 4.3l-.8 5.7h-2.8l.8-5.4c.2-1.2-.4-2.1-1.7-2.1s-2.1 1-2.2 2l-.8 5.4z"/><path d="M119.4 101.1l.4-3h2.8l-.4 3h2.4l-.3 2.2h-2.4l-.6 4.4c-.1.7.2 1.1.9 1.1.6 0 1.1-.3 1.1-.3l.5 1.9c-.4.3-1.5.8-2.6.8-2.3 0-3-1.4-2.7-3.4l.6-4.5h-1.7l.3-2.2h1.7zm14.9 9.7h-5.1l1.9-13.9h5.1c4 0 6.4 2.5 6.4 6 0 4.6-3.5 7.9-8.3 7.9m-.7-11.4l-1.3 9h2.1c2.8 0 5.2-1.9 5.2-5.2 0-2.5-1.7-3.8-4-3.8h-2z"/><path d="M151 102.4l.6-1.3h1.8l-1.4 9.7h-1.8l-.3-1.3h-.1s-1 1.6-3.4 1.6c-2.3 0-3.9-1.7-3.9-4.3 0-3.4 2.5-5.9 5.3-5.9 2.4 0 3 1.6 3 1.6h.2zm-2.9.7c-1.5 0-2.7 1.4-2.7 3.2 0 1.4.7 2.4 1.9 2.4 1.6 0 2.8-1.3 2.8-3.3.1-1.4-.7-2.3-2-2.3m6.4-2h2.8l-1.4 9.7h-2.8l1.4-9.7zm.2-2.9c0-1 .9-1.8 1.9-1.8.8 0 1.4.6 1.4 1.4 0 1-.9 1.8-1.9 1.8-.9 0-1.4-.6-1.4-1.4m4.7-1.4h2.8l-2 14h-2.8zm12.5 4.3l-1.3 9.2c-.4 2.7-2.3 4.7-5.6 4.7-2 0-3.2-.9-3.7-1.5l1.6-1.7c.3.4 1 1 2.4 1 1.5 0 2.4-.9 2.6-2.4l.1-.5c-.6.5-1.6 1.1-2.9 1.1-2.6 0-3.8-1.7-3.5-4.3l.8-5.6h2.8l-.8 5.4c-.2 1.3.3 2.2 1.6 2.2s2.2-.9 2.4-1.9l.8-5.7h2.7z"/></symbol><symbol viewBox="0 0 48 48" id="icon-search"><path d="M31 28h-2v-1c2-2 3-5 3-8a13 13 0 1 0-5 10h1v2l10 10 3-3-10-10zm-12 0a9 9 0 1 1 0-18 9 9 0 0 1 0 18z"/></symbol></svg></div>

<div id="wrapper">

	<header class="text-white">

        <div class="bg-brand py-1 relative">

            <div class="container flex justify-between">

                <a href="/" aria-label="Home">
                    <svg class="w-16 h-12 md:w-24 md:h-16 lg:w-32 lg:h-24 fill-current"><use xlink:href="#icon-logo"></use></svg>
                </a>

                <div class="absolute -mb-4 bottom-0 z-10 hidden lg:block">
                    <a class="sr-only focus:not-sr-only text-brand bg-white block whitespace-no-wrap" href="#content">Skip to content</a>
                </div>

                <div class="flex-grow hidden sm:block px-6 md:mt-2 lg:mt-6">
                    <div class="text-white text-opacity-75 italic whitespace-no-wrap md:text-lg">
                        All the latest TV, showbiz &amp; more                    </div>
                    <div class="text-white text-opacity-75 text-sm">
                        Friday 10th September 2021                    </div>
                </div>

                <button id="nav-toggle" class="px-4 text-2xl lg:hidden" aria-controls="nav-menu" aria-expanded="false" aria-label="Menu">
                    ☰
                </button>

            </div>

        </div>

		<nav id="nav-menu" class="hidden bg-brand-dark text-right leading-relaxed lg:block">

            <div class="container relative">

                <div class="absolute z-50 right-0 px-4 py-2 bg-brand md:px-12 lg:p-0 lg:block lg:static lg:bg-brand-dark lg:w-auto">
                    <ul class="uppercase font-medium underline lg:no-underline lg:flex lg:justify-between">
                    <li><a href="https://www.entertainmentdaily.co.uk/news/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">News</a></li><li class="group"><a href="https://www.entertainmentdaily.co.uk/tv/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative bg-brand"><span class="text-xs invisible lg:visible">&#9660; </span>TV</a><ul class="bg-brand-dark normal-case p-2 z-50 no-underline lg:hidden lg:absolute lg:text-left group-hover:block"><li><a href="https://www.entertainmentdaily.co.uk/good-morning-britain/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Good Morning Britain</a></li><li><a href="https://www.entertainmentdaily.co.uk/loose-women/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Loose Women</a></li><li><a href="https://www.entertainmentdaily.co.uk/the-chase/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">The Chase</a></li><li><a href="https://www.entertainmentdaily.co.uk/this-morning/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">This Morning</a></li><li><a href="https://www.entertainmentdaily.co.uk/saturday-night-takeaway/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Saturday Night Takeaway</a></li><li><a href="https://www.entertainmentdaily.co.uk/netflix/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Netflix</a></li></ul></li><li class="group"><a href="https://www.entertainmentdaily.co.uk/soaps/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative"><span class="text-xs invisible lg:visible">&#9660; </span>Soaps</a><ul class="bg-brand-dark normal-case p-2 z-50 no-underline lg:hidden lg:absolute lg:text-left group-hover:block"><li><a href="https://www.entertainmentdaily.co.uk/coronation-street/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Coronation Street</a></li><li><a href="https://www.entertainmentdaily.co.uk/eastenders/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">EastEnders</a></li><li><a href="https://www.entertainmentdaily.co.uk/emmerdale/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Emmerdale</a></li></ul></li><li><a href="https://www.entertainmentdaily.co.uk/royals/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Royals</a></li><li><a href="https://www.entertainmentdaily.co.uk/lifestyle/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Lifestyle</a></li><li><a href="https://www.entertainmentdaily.co.uk/strictly-come-dancing/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Strictly Come Dancing</a></li>                    </ul>
                    <a href="https://www.facebook.com/entertainmentdailyfix/" class="lg:absolute lg:bottom-0 lg:right-0 lg:mr-12 lg:mb-16 lg:mx-3">
                        <svg class="w-8 h-8 fill-current inline-block my-3"><use xlink:href="#icon-facebook"></use></svg>
                    </a>
                </div>

            </div>

        </nav>

	</header>

    <div id="content" class="container py-1">

    <main>

        <div class="lg:flex lg:min-h-screen">

            <div class="flex-shrink">

                <div class="flex sm:inline-flex lg:mb-2 justify-between uppercase mb-1 lg:mt-1 text-white text-right">
                    <a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.entertainmentdaily.co.uk%2Ftv%2Fnational-television-awards-joel-dommett-praised-by-viewers-but-they-all-have-one-question-about-his-appearance%2F"
                       class="share-fb flex-1" target="_blank" aria-label="Share on Facebook" tabindex="-1">Share</a>
                    <a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.entertainmentdaily.co.uk%2Ftv%2Fnational-television-awards-joel-dommett-praised-by-viewers-but-they-all-have-one-question-about-his-appearance%2F&text=National+Television+Awards%3A+Joel+Dommett+praised+by+viewers+but+they+all+have+one+question+about+his+appearance"
                       class="share-twitter flex-1" target="_blank" aria-label="Share on Twitter"
                       tabindex="-1">Share</a>
                    <a href="https://wa.me/?text=https%3A%2F%2Fwww.entertainmentdaily.co.uk%2Ftv%2Fnational-television-awards-joel-dommett-praised-by-viewers-but-they-all-have-one-question-about-his-appearance%2F+National+Television+Awards%3A+Joel+Dommett+praised+by+viewers+but+they+all+have+one+question+about+his+appearance"
                       class="share-whatsapp flex-1 sm:hidden" target="_blank" aria-label="Share on WhatsApp"
                       tabindex="-1">Share</a>
                </div>

                <article class="lg:mr-20 js-article">
                                            <div class="force-aspect placeholder"
                                                            style="background: url(https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-180x94.jpg) no-repeat; background-size: cover;"
                                                    >
                            <img class="w-full absolute inset-0 lazyload" sizes="(min-width: 1024px) 660px, 100vw" data-src="https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27.jpg 1500w, https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-400x209.jpg 400w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-742x388.jpg" alt="" class="w-full absolute inset-0 lazyload"></noscript>                        </div>
                    
                                            <a class="px-1 lg:mt-2 inline-block bg-brand text-white uppercase text-xs"
                           href="https://www.entertainmentdaily.co.uk/tv/">TV</a>
                    
                    <h1 class="text-brand text-2xl font-semibold leading-none lg:text-3xl">
                        National Television Awards: Joel Dommett praised by viewers but they all have one question about his appearance                    </h1>

                    <h2 class="text-gray-800 font-medium leading-tight text-lg my-1 lg:mb-3">
                        Viewers also                     </h2>

                    <div class="text-xs clearfix leading-tight mb-2 lg:leading-relaxed lg:float-left lg:w-32">
                                                <div class="h-8 flex flex-col justify-center lg:block">
                            <div class="text-brand">
                                <span class="lg:hidden">By</span> <a
                                        href="https://www.entertainmentdaily.co.uk/author/paul-hirons/">Paul Hirons</a>
                            </div>
                            <div>
                                <time datetime="2021-09-10T13:06:16+01:00"
                                      aria-label="Published at">10 Sep 2021, 13:06</time>
                                                            </div>

                                                            <div class="hidden text-xs lg:block">
                                    Tags:
                                                                            <a href="/joel-dommett/"
                                           class="text-brand">Joel Dommett</a>,                                                                            <a href="/national-television-awards/"
                                           class="text-brand">National Television Awards</a>,                                                                            <a href="/ntas/"
                                           class="text-brand">NTAs</a>                                                                    </div>
                                                    </div>

                    </div>

                    <div class="drop-cap rich-text mx-auto sm:max-w-md md:max-w-lg lg:ml-40 lg:mt-3 js-article-body">
                        <div id="i4c-draggable-container" style="position: fixed; z-index: 1499; width: 0px; height: 0px;">
<div class="resolved" style="all: initial;" data-reactroot=""></div>
</div>
<p>Viewers of the <a href="https://www.entertainmentdaily.co.uk/national-television-awards" target="_blank" rel="noopener">National Television Awards</a> praised host <a href="https://www.entertainmentdaily.co.uk/joel-dommett" target="_blank" rel="noopener">Joel Dommett</a> last night (Thursday September 10) and called for him to be a permanent fixture.</p>
<p>Joel, 36, has become ITV&#8217;s golden boy after proving to be a skilled host during series of The Masked Dancer and The Masked Singer.</p>
<p>And now viewers are calling for him to be a permanent host of the NTAs, too. But they were distracted by another feature: his teeth.</p>

<figure>
	<div class="relative bg-gray-200" style="padding-top: 55.75%">
		<img class="w-full absolute inset-0 lazyload" data-src="https://cdn.entertainmentdaily.com/2021/09/10105754/Screenshot-2021-09-10-at-10.57.06-400x223.png" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10105754/Screenshot-2021-09-10-at-10.57.06-800x445.png 800w, https://cdn.entertainmentdaily.com/2021/09/10105754/Screenshot-2021-09-10-at-10.57.06-768x427.png 768w, https://cdn.entertainmentdaily.com/2021/09/10105754/Screenshot-2021-09-10-at-10.57.06-400x223.png 400w, https://cdn.entertainmentdaily.com/2021/09/10105754/Screenshot-2021-09-10-at-10.57.06.png 1395w" sizes="(min-width: 500px) 500px, 100vw" alt="Joel Dommett presenting the National Television Awards">
		<noscript>
			<img class="w-full absolute inset-0" src="https://cdn.entertainmentdaily.com/2021/09/10105754/Screenshot-2021-09-10-at-10.57.06-400x223.png" srcset="https://cdn.entertainmentdaily.com/2021/09/10105754/Screenshot-2021-09-10-at-10.57.06-800x445.png 800w, https://cdn.entertainmentdaily.com/2021/09/10105754/Screenshot-2021-09-10-at-10.57.06-768x427.png 768w, https://cdn.entertainmentdaily.com/2021/09/10105754/Screenshot-2021-09-10-at-10.57.06-400x223.png 400w, https://cdn.entertainmentdaily.com/2021/09/10105754/Screenshot-2021-09-10-at-10.57.06.png 1395w" alt="Joel Dommett presenting the National Television Awards">		
		</noscript>
	</div>
<figcaption class='text-sm italic leading-tight mt-1'>Viewers gave their verdict on Joel&#8217;s skills (Credit: ITV)</figcaption>
</figure>

<h3>What happened with Joel Dommett at the National Television Awards last night?</h3>
<p>The great and the good gathered at The O2 arena in London, and added some much-needed glam and fun to viewers&#8217; lives after a torrid year.</p>
<p>Ahead of the show, he told the <a href="https://www.radiotimes.com/tv/entertainment/ntas-2021-joel-dommett-advice-dermot-oleary-exclusive-newsupdate/" target="_blank" rel="noopener">Radio Times</a> that his predecessors, Dermot O&#8217;Leary and David Walliams, gave him some advice.</p>
<p><strong>Read more: <a href="https://www.entertainmentdaily.co.uk/tv/ntas-tonight-all-the-former-national-television-awards-presenters-as-joel-dommett-takes-over/" target="_blank" rel="noopener">NTAs tonight: All the former National Television Awards presenters as Joel Dommett takes over</a></strong></p>
<p>&#8220;Dermot’s been great, I went for lunch with him and he’s been wonderful,&#8221; Joel said.</p>
<p>&#8220;It is really important to speak to Dermot and David and just kind of get sort of an understanding of how it feels to be there on stage.</p>
<p>&#8220;They all say the same thing really: ‘Just enjoy it.’&#8221;</p>
<p>And enjoy it Joel definitely did, heading up a feel-good, fun and sometimes emotional ceremony.</p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">After a couple of underwhelming and predictable years, I think the <a href="https://twitter.com/hashtag/NTAs?src=hash&amp;ref_src=twsrc%5Etfw">#NTAs</a> were brilliant tonight. Joel Dommett was an excellent host who should definitely return next year. Not only a slick show, but some surprising and well deserved wins across the board.</p>
<p>&mdash; Elliot Gonzalez (@elliot_gonzalez) <a href="https://twitter.com/elliot_gonzalez/status/1436073771866132480?ref_src=twsrc%5Etfw">September 9, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">Choosing Joel Dommett to host the <a href="https://twitter.com/hashtag/NTAs?src=hash&amp;ref_src=twsrc%5Etfw">#NTAs</a> was an excellent choice excellent presenter and obvs eye candy 😍</p>
<p>&mdash; Caroline Day (@Caroline_Day) <a href="https://twitter.com/Caroline_Day/status/1436044097303810051?ref_src=twsrc%5Etfw">September 9, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">Loving the <a href="https://twitter.com/hashtag/NTAs?src=hash&amp;ref_src=twsrc%5Etfw">#NTAs</a> so far. Joel Dommett is doing great at presenting. And absolutely buzzing Line of Duty won 🎉🎉</p>
<p>&mdash; Jessi ☕️🦩 (@jessiloumilton) <a href="https://twitter.com/jessiloumilton/status/1436043766117326854?ref_src=twsrc%5Etfw">September 9, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">Joel Dommett is absolutely BRILLIANT <a href="https://twitter.com/hashtag/NTAs?src=hash&amp;ref_src=twsrc%5Etfw">#NTAs</a></p>
<p>&mdash; Calli Kitson (@callikitson) <a href="https://twitter.com/callikitson/status/1436039779250999308?ref_src=twsrc%5Etfw">September 9, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">So Joel Dommett is smashing at this <a href="https://twitter.com/hashtag/NTAs?src=hash&amp;ref_src=twsrc%5Etfw">#NTAs</a></p>
<p>&mdash; Laura Jane Turner #blacklivesmatter (@ljaneturner) <a href="https://twitter.com/ljaneturner/status/1436045558720892932?ref_src=twsrc%5Etfw">September 9, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<h3>How did viewers react to Joel&#8217;s presenting skills?</h3>
<p>Throughout the ceremony, viewers took to Twitter to give Joel a big thumbs up.</p>
<p>&#8220;So Joel Dommett is smashing at this #NTAs,&#8221; one wrote.</p>
<p>Another said: &#8220;Joel Dommett is absolutely BRILLIANT #NTAs.&#8221;</p>
<p>A third commented: &#8220;Choosing Joel Dommett to host the #NTAs was an excellent choice. Excellent presenter and obvs eye candy.&#8221;</p>
<p>Finally one viewer said: &#8220;After a couple of underwhelming and predictable years, I think the #NTAs were brilliant tonight.</p>
<p>&#8220;Joel Dommett was an excellent host who should definitely return next year.</p>
<p>&#8220;Not only a slick show, but some surprising and well deserved wins across the board.&#8221;</p>

<figure>
	<div class="relative bg-gray-200" style="padding-top: 56%">
		<img class="w-full absolute inset-0 lazyload" data-src="https://cdn.entertainmentdaily.com/2021/09/10104930/Screenshot-2021-09-10-at-10.42.54-400x224.png" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10104930/Screenshot-2021-09-10-at-10.42.54-800x448.png 800w, https://cdn.entertainmentdaily.com/2021/09/10104930/Screenshot-2021-09-10-at-10.42.54-768x430.png 768w, https://cdn.entertainmentdaily.com/2021/09/10104930/Screenshot-2021-09-10-at-10.42.54-400x224.png 400w, https://cdn.entertainmentdaily.com/2021/09/10104930/Screenshot-2021-09-10-at-10.42.54.png 1390w" sizes="(min-width: 500px) 500px, 100vw" alt="Joel Dommett presenting the National Television Awards">
		<noscript>
			<img class="w-full absolute inset-0" src="https://cdn.entertainmentdaily.com/2021/09/10104930/Screenshot-2021-09-10-at-10.42.54-400x224.png" srcset="https://cdn.entertainmentdaily.com/2021/09/10104930/Screenshot-2021-09-10-at-10.42.54-800x448.png 800w, https://cdn.entertainmentdaily.com/2021/09/10104930/Screenshot-2021-09-10-at-10.42.54-768x430.png 768w, https://cdn.entertainmentdaily.com/2021/09/10104930/Screenshot-2021-09-10-at-10.42.54-400x224.png 400w, https://cdn.entertainmentdaily.com/2021/09/10104930/Screenshot-2021-09-10-at-10.42.54.png 1390w" alt="Joel Dommett presenting the National Television Awards">		
		</noscript>
	</div>
<figcaption class='text-sm italic leading-tight mt-1'>Joel&#8217;s teeth came under scrutiny (Credit: ITV)</figcaption>
</figure>

<h3>What was the deal with Joel&#8217;s teeth?</h3>
<p>However, some viewers weren&#8217;t quite so charitable.</p>
<p>Some noticed the&#8230; prominence and whiteness of Joel&#8217;s teeth.</p>
<p><strong>Read more: <a href="https://www.entertainmentdaily.co.uk/news/kate-garraway-reveals-moment-she-told-husband-derek-draper-about-ntas-win/" target="_blank" rel="noopener">Kate Garraway reveals moment she told husband Derek Draper about NTAs win</a></strong></p>
<p>One said: &#8220;Love @joeldommett but your teeth are too big for you’re mouth makes ya talk funny sorry but very awks #NTAs #joeldommett.&#8221;</p>
<p>Another asked: &#8220;#NTAwards Has Joel Dommett false teeth?&#8221;</p>
<p>A third commented: &#8220;Joel has his teeth done [surprised emoji].&#8221;</p>
<p><iframe loading="lazy" title="Joel Dommett Appears Topless Live on Air After Rolling Out of Bed | Lorraine" width="500" height="281" src="https://www.youtube.com/embed/OL-ZgvT--Vo?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<blockquote><p><strong><i>Leave us a comment on <a href="https://www.facebook.com/entertainmentdailyfix">our Facebook page @EntertainmentDailyFix</a></i></strong><i> </i><strong><i>and let us know what you think of this story.</i></strong></p></blockquote>

<div id="i4c-dialogs-container"></div>
<div id="i4c-dialogs-container"></div>
<div id="i4c-dialogs-container"></div>
<div id="i4c-dialogs-container"></div>
                    </div>

	                
                    <div class="flex sm:inline-flex justify-between uppercase my-1 text-white text-right lg:ml-40">
                        <a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.entertainmentdaily.co.uk%2Ftv%2Fnational-television-awards-joel-dommett-praised-by-viewers-but-they-all-have-one-question-about-his-appearance%2F"
                           class="share-fb flex-1" target="_blank" aria-label="Share on Facebook">Share</a>
                        <a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.entertainmentdaily.co.uk%2Ftv%2Fnational-television-awards-joel-dommett-praised-by-viewers-but-they-all-have-one-question-about-his-appearance%2F&text=National+Television+Awards%3A+Joel+Dommett+praised+by+viewers+but+they+all+have+one+question+about+his+appearance"
                           class="share-twitter flex-1" target="_blank" aria-label="Share on Twitter">Share</a>
                        <a href="https://wa.me/?text=https%3A%2F%2Fwww.entertainmentdaily.co.uk%2Ftv%2Fnational-television-awards-joel-dommett-praised-by-viewers-but-they-all-have-one-question-about-his-appearance%2F+National+Television+Awards%3A+Joel+Dommett+praised+by+viewers+but+they+all+have+one+question+about+his+appearance"
                           class="share-whatsapp flex-1 sm:hidden" target="_blank" aria-label="Share on WhatsApp">Share</a>
                    </div>

                                            <div class="text-sm my-6 lg:ml-40">
                            <h3 class="italic uppercase">Related Topics</h3>
                            <div>
                                                                    <a href="/joel-dommett/"
                                       class="bg-brand text-white px-1">Joel Dommett</a>
                                                                    <a href="/national-television-awards/"
                                       class="bg-brand text-white px-1">National Television Awards</a>
                                                                    <a href="/ntas/"
                                       class="bg-brand text-white px-1">NTAs</a>
                                                            </div>
                        </div>
                    
                </article>

                
            </div>

            <aside class="flex-sidebar js-sidebar">
		                            <div class="my-6 py-2 bg-gray-200 border-t-2 border-brand text-sm leading-tight">
                        <h3 class="px-3 uppercase italic text-sm">More TV</h3>
                        <div class="flex flex-wrap text-brand mr-3">
					                                        <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                    <div class="ml-3">
								                                                    <div class="force-aspect mb-px">
                                                <a href="https://www.entertainmentdaily.co.uk/tv/opinion-stephen-mulhern-is-brilliant-and-deserves-justice-after-snub-at-the-2021-ntas/" tabindex="-1">
											        <img class="w-full absolute inset-0 lazyload" alt="NTAs 2021" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2021/09/10125041/Stephen-Mulhern-742x388.png" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10125041/Stephen-Mulhern-742x388.png 742w, https://cdn.entertainmentdaily.com/2021/09/10125041/Stephen-Mulhern-768x401.png 768w, https://cdn.entertainmentdaily.com/2021/09/10125041/Stephen-Mulhern-360x188.png 360w, https://cdn.entertainmentdaily.com/2021/09/10125041/Stephen-Mulhern-180x94.png 180w, https://cdn.entertainmentdaily.com/2021/09/10125041/Stephen-Mulhern-800x418.png 800w, https://cdn.entertainmentdaily.com/2021/09/10125041/Stephen-Mulhern-400x209.png 400w, https://cdn.entertainmentdaily.com/2021/09/10125041/Stephen-Mulhern.png 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/09/10125041/Stephen-Mulhern-742x388.png" alt="NTAs 2021" class="w-full absolute inset-0 lazyload"></noscript>                                                </a>
                                            </div>
								                                                <a href="https://www.entertainmentdaily.co.uk/tv/opinion-stephen-mulhern-is-brilliant-and-deserves-justice-after-snub-at-the-2021-ntas/">
									        OPINION: Stephen Mulhern is brilliant and deserves justice after snub at the 2021 NTAs                                        </a>
                                    </div>
                                </div>
					                                        <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                    <div class="ml-3">
								                                                    <div class="force-aspect mb-px">
                                                <a href="https://www.entertainmentdaily.co.uk/tv/gogglebox-stars-defended-as-viewers-accuse-them-of-being-drunk-during-ntas-speech/" tabindex="-1">
											        <img class="w-full absolute inset-0 lazyload" alt="Gogglebox at the NTAs" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2021/09/10120622/Gogglebox-NTAs-3-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10120622/Gogglebox-NTAs-3-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2021/09/10120622/Gogglebox-NTAs-3-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2021/09/10120622/Gogglebox-NTAs-3-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2021/09/10120622/Gogglebox-NTAs-3-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2021/09/10120622/Gogglebox-NTAs-3-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2021/09/10120622/Gogglebox-NTAs-3-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2021/09/10120622/Gogglebox-NTAs-3.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/09/10120622/Gogglebox-NTAs-3-742x388.jpg" alt="Gogglebox at the NTAs" class="w-full absolute inset-0 lazyload"></noscript>                                                </a>
                                            </div>
								                                                <a href="https://www.entertainmentdaily.co.uk/tv/gogglebox-stars-defended-as-viewers-accuse-them-of-being-drunk-during-ntas-speech/">
									        Gogglebox stars defended as viewers accuse them of being &#8216;drunk&#8217; during NTAs speech                                        </a>
                                    </div>
                                </div>
					                                        <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                    <div class="ml-3">
								                                                    <div class="force-aspect mb-px">
                                                <a href="https://www.entertainmentdaily.co.uk/tv/review-the-big-breakfast-reboot-has-woken-up-a-sleepy-tv-landscape/" tabindex="-1">
											        <img class="w-full absolute inset-0 lazyload" alt="AJ Odudu &amp; Mo Gilligan host The Big Breakfast" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2021/09/10113444/The-Big-Breakfast-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10113444/The-Big-Breakfast-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2021/09/10113444/The-Big-Breakfast-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2021/09/10113444/The-Big-Breakfast-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2021/09/10113444/The-Big-Breakfast-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2021/09/10113444/The-Big-Breakfast-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2021/09/10113444/The-Big-Breakfast-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2021/09/10113444/The-Big-Breakfast.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/09/10113444/The-Big-Breakfast-742x388.jpg" alt="AJ Odudu &amp; Mo Gilligan host The Big Breakfast" class="w-full absolute inset-0 lazyload"></noscript>                                                </a>
                                            </div>
								                                                <a href="https://www.entertainmentdaily.co.uk/tv/review-the-big-breakfast-reboot-has-woken-up-a-sleepy-tv-landscape/">
									        REVIEW: The Big Breakfast Reboot has woken up a sleepy TV landscape                                        </a>
                                    </div>
                                </div>
					                                        <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                    <div class="ml-3">
								                                                    <div class="force-aspect mb-px">
                                                <a href="https://www.entertainmentdaily.co.uk/tv/opinion-this-morning-stars-kissing-as-show-wins-nta-and-distancing-on-screen-is-just-silly/" tabindex="-1">
											        <img class="w-full absolute inset-0 lazyload" alt="this morning Nta" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2021/09/10111516/This-Morning-stars-742x388.png" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10111516/This-Morning-stars-742x388.png 742w, https://cdn.entertainmentdaily.com/2021/09/10111516/This-Morning-stars-768x401.png 768w, https://cdn.entertainmentdaily.com/2021/09/10111516/This-Morning-stars-360x188.png 360w, https://cdn.entertainmentdaily.com/2021/09/10111516/This-Morning-stars-180x94.png 180w, https://cdn.entertainmentdaily.com/2021/09/10111516/This-Morning-stars-800x418.png 800w, https://cdn.entertainmentdaily.com/2021/09/10111516/This-Morning-stars-400x209.png 400w, https://cdn.entertainmentdaily.com/2021/09/10111516/This-Morning-stars.png 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/09/10111516/This-Morning-stars-742x388.png" alt="this morning Nta" class="w-full absolute inset-0 lazyload"></noscript>                                                </a>
                                            </div>
								                                                <a href="https://www.entertainmentdaily.co.uk/tv/opinion-this-morning-stars-kissing-as-show-wins-nta-and-distancing-on-screen-is-just-silly/">
									        OPINION: This Morning stars kissing as show wins NTA and distancing on screen is just silly                                        </a>
                                    </div>
                                </div>
					                                        <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                    <div class="ml-3">
								                                                    <div class="force-aspect mb-px">
                                                <a href="https://www.entertainmentdaily.co.uk/tv/celebrity-masterchef-bez-fans-threaten-to-switch-off-as-star-is-evicted/" tabindex="-1">
											        <img class="w-full absolute inset-0 lazyload" alt="Bez on Celebrity MasterChef" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2021/09/10111319/Celebrity-MasterChef-Bez-2-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10111319/Celebrity-MasterChef-Bez-2-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2021/09/10111319/Celebrity-MasterChef-Bez-2-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2021/09/10111319/Celebrity-MasterChef-Bez-2-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2021/09/10111319/Celebrity-MasterChef-Bez-2-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2021/09/10111319/Celebrity-MasterChef-Bez-2-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2021/09/10111319/Celebrity-MasterChef-Bez-2-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2021/09/10111319/Celebrity-MasterChef-Bez-2.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/09/10111319/Celebrity-MasterChef-Bez-2-742x388.jpg" alt="Bez on Celebrity MasterChef" class="w-full absolute inset-0 lazyload"></noscript>                                                </a>
                                            </div>
								                                                <a href="https://www.entertainmentdaily.co.uk/tv/celebrity-masterchef-bez-fans-threaten-to-switch-off-as-star-is-evicted/">
									        Celebrity MasterChef viewers threaten to &#8216;switch off&#8217; as Bez is eliminated                                        </a>
                                    </div>
                                </div>
					                                        <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                    <div class="ml-3">
								                                                    <div class="force-aspect mb-px">
                                                <a href="https://www.entertainmentdaily.co.uk/tv/martin-compston-and-wife-cheekily-told-to-get-a-room-after-pda-at-ntas/" tabindex="-1">
											        <img class="w-full absolute inset-0 lazyload" alt="Martin Compston and wife pack on PDA at NTAs" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2021/09/10110806/martin-compston-and-wife-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10110806/martin-compston-and-wife-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2021/09/10110806/martin-compston-and-wife-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2021/09/10110806/martin-compston-and-wife-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2021/09/10110806/martin-compston-and-wife-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2021/09/10110806/martin-compston-and-wife-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2021/09/10110806/martin-compston-and-wife-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2021/09/10110806/martin-compston-and-wife.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/09/10110806/martin-compston-and-wife-742x388.jpg" alt="Martin Compston and wife pack on PDA at NTAs" class="w-full absolute inset-0 lazyload"></noscript>                                                </a>
                                            </div>
								                                                <a href="https://www.entertainmentdaily.co.uk/tv/martin-compston-and-wife-cheekily-told-to-get-a-room-after-pda-at-ntas/">
									        Martin Compston and wife cheekily told to &#8216;get a room&#8217; after PDA at NTAs                                        </a>
                                    </div>
                                </div>
					                                </div>
                    </div>
		        
                <div class="my-6 py-2 bg-gray-200 border-t-2 border-brand text-sm leading-tight">
                    <h3 class="px-3 uppercase italic text-sm">Latest News</h3>
                    <div class="flex flex-wrap text-brand mr-3">
				        
                            <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                <div class="ml-3">
							                                                <div class="force-aspect mb-px">
                                            <a href="https://www.entertainmentdaily.co.uk/tv/national-television-awards-joel-dommett-praised-by-viewers-but-they-all-have-one-question-about-his-appearance/" tabindex="-1">
										        <img class="w-full absolute inset-0 lazyload" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/09/10110209/Untitled-27-742x388.jpg" alt="" class="w-full absolute inset-0 lazyload"></noscript>                                            </a>
                                        </div>
							                                            <a href="https://www.entertainmentdaily.co.uk/tv/national-television-awards-joel-dommett-praised-by-viewers-but-they-all-have-one-question-about-his-appearance/">
								        National Television Awards: Joel Dommett praised by viewers but they all have one question about his appearance                                    </a>
                                </div>
                            </div>

				        
                            <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                <div class="ml-3">
							                                                <div class="force-aspect mb-px">
                                            <a href="https://www.entertainmentdaily.co.uk/tv/gogglebox-star-pete-sandiford-welcomes-baby-son-with-partner-paige-yeomans/" tabindex="-1">
										        <img class="w-full absolute inset-0 lazyload" alt="Gogglebox star Pete Sandiford" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2021/09/10102615/Gogglebox-Pete-1-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10102615/Gogglebox-Pete-1-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2021/09/10102615/Gogglebox-Pete-1-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2021/09/10102615/Gogglebox-Pete-1-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2021/09/10102615/Gogglebox-Pete-1-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2021/09/10102615/Gogglebox-Pete-1-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2021/09/10102615/Gogglebox-Pete-1-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2021/09/10102615/Gogglebox-Pete-1.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/09/10102615/Gogglebox-Pete-1-742x388.jpg" alt="Gogglebox star Pete Sandiford" class="w-full absolute inset-0 lazyload"></noscript>                                            </a>
                                        </div>
							                                            <a href="https://www.entertainmentdaily.co.uk/tv/gogglebox-star-pete-sandiford-welcomes-baby-son-with-partner-paige-yeomans/">
								        Gogglebox star Pete Sandiford welcomes baby son with partner Paige Yeomans                                    </a>
                                </div>
                            </div>

				        
                            <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                <div class="ml-3">
							                                                <div class="force-aspect mb-px">
                                            <a href="https://www.entertainmentdaily.co.uk/tv/ntas-2021-viewers-claim-theyre-distracted-by-holly-willoughbys-black-knickers/" tabindex="-1">
										        <img class="w-full absolute inset-0 lazyload" alt="ntas 2021" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2021/09/10100949/Holly-on-stage-at-the-NTAs-742x388.png" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10100949/Holly-on-stage-at-the-NTAs-742x388.png 742w, https://cdn.entertainmentdaily.com/2021/09/10100949/Holly-on-stage-at-the-NTAs-768x401.png 768w, https://cdn.entertainmentdaily.com/2021/09/10100949/Holly-on-stage-at-the-NTAs-360x188.png 360w, https://cdn.entertainmentdaily.com/2021/09/10100949/Holly-on-stage-at-the-NTAs-180x94.png 180w, https://cdn.entertainmentdaily.com/2021/09/10100949/Holly-on-stage-at-the-NTAs-800x418.png 800w, https://cdn.entertainmentdaily.com/2021/09/10100949/Holly-on-stage-at-the-NTAs-400x209.png 400w, https://cdn.entertainmentdaily.com/2021/09/10100949/Holly-on-stage-at-the-NTAs.png 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/09/10100949/Holly-on-stage-at-the-NTAs-742x388.png" alt="ntas 2021" class="w-full absolute inset-0 lazyload"></noscript>                                            </a>
                                        </div>
							                                            <a href="https://www.entertainmentdaily.co.uk/tv/ntas-2021-viewers-claim-theyre-distracted-by-holly-willoughbys-black-knickers/">
								        NTAs 2021: Viewers claim they&#8217;re distracted by Holly Willoughby&#8217;s &#8216;black knickers&#8217;                                    </a>
                                </div>
                            </div>

				        
                            <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                <div class="ml-3">
							                                                <div class="force-aspect mb-px">
                                            <a href="https://www.entertainmentdaily.co.uk/news/eastenders-spoilers-tonight-whats-happening-on-friday-september-10-2021/" tabindex="-1">
										        <img class="w-full absolute inset-0 lazyload" alt="EastEnders spoilers Phil Janine" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2021/09/10104747/Phil-Janine-EastEnders-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10104747/Phil-Janine-EastEnders-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2021/09/10104747/Phil-Janine-EastEnders-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2021/09/10104747/Phil-Janine-EastEnders-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2021/09/10104747/Phil-Janine-EastEnders-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2021/09/10104747/Phil-Janine-EastEnders-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2021/09/10104747/Phil-Janine-EastEnders-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2021/09/10104747/Phil-Janine-EastEnders.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/09/10104747/Phil-Janine-EastEnders-742x388.jpg" alt="EastEnders spoilers Phil Janine" class="w-full absolute inset-0 lazyload"></noscript>                                            </a>
                                        </div>
							                                            <a href="https://www.entertainmentdaily.co.uk/news/eastenders-spoilers-tonight-whats-happening-on-friday-september-10-2021/">
								        EastEnders spoilers tonight: What&#8217;s happening on Friday, September 10 2021                                    </a>
                                </div>
                            </div>

				        
                            <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                <div class="ml-3">
							                                                <div class="force-aspect mb-px">
                                            <a href="https://www.entertainmentdaily.co.uk/news/kate-garraway-reveals-moment-she-told-husband-derek-draper-about-ntas-win/" tabindex="-1">
										        <img class="w-full absolute inset-0 lazyload" alt="Kate Garraway and husband Derek Draper" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2021/09/10102118/kate-garraway-derek-draper-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10102118/kate-garraway-derek-draper-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2021/09/10102118/kate-garraway-derek-draper-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2021/09/10102118/kate-garraway-derek-draper-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2021/09/10102118/kate-garraway-derek-draper-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2021/09/10102118/kate-garraway-derek-draper-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2021/09/10102118/kate-garraway-derek-draper-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2021/09/10102118/kate-garraway-derek-draper.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/09/10102118/kate-garraway-derek-draper-742x388.jpg" alt="Kate Garraway and husband Derek Draper" class="w-full absolute inset-0 lazyload"></noscript>                                            </a>
                                        </div>
							                                            <a href="https://www.entertainmentdaily.co.uk/news/kate-garraway-reveals-moment-she-told-husband-derek-draper-about-ntas-win/">
								        Kate Garraway reveals moment she told husband Derek Draper about NTAs win                                    </a>
                                </div>
                            </div>

				        
                            <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                <div class="ml-3">
							                                                <div class="force-aspect mb-px">
                                            <a href="https://www.entertainmentdaily.co.uk/tv/david-tennant-and-wife-georgia-tennant-set-to-star-together-in-new-jekyll-and-hyde-series-hide/" tabindex="-1">
										        <img class="w-full absolute inset-0 lazyload" alt="David Tennant and Georgia Moffat star in Staged" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2021/09/10092840/Untitled-2021-09-10T092751.983-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2021/09/10092840/Untitled-2021-09-10T092751.983-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2021/09/10092840/Untitled-2021-09-10T092751.983-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2021/09/10092840/Untitled-2021-09-10T092751.983-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2021/09/10092840/Untitled-2021-09-10T092751.983-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2021/09/10092840/Untitled-2021-09-10T092751.983-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2021/09/10092840/Untitled-2021-09-10T092751.983-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2021/09/10092840/Untitled-2021-09-10T092751.983.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/09/10092840/Untitled-2021-09-10T092751.983-742x388.jpg" alt="David Tennant and Georgia Moffat star in Staged" class="w-full absolute inset-0 lazyload"></noscript>                                            </a>
                                        </div>
							                                            <a href="https://www.entertainmentdaily.co.uk/tv/david-tennant-and-wife-georgia-tennant-set-to-star-together-in-new-jekyll-and-hyde-series-hide/">
								        David Tennant and wife Georgia set to star together in new Jekyll and Hyde series Hide                                    </a>
                                </div>
                            </div>

				                            </div>
                </div>
            </aside>

        </div>

    </main>

    </div>

    <footer class="bg-brand-dark text-white border-t-8 border-brand mt-2 px-2 py-12">
        <div class="container">

            <div class="flex">
                <div class="sm:flex-1">
                    <a href="/" aria-label="Home">
                        <svg class="w-24 h-16 inline-block fill-current"><use xlink:href="#icon-logo"></use></svg>
                    </a>
                </div>
                <div class="flex-1 inline-block text-white ">
                    <form action="https://www.entertainmentdaily.co.uk/" class="mt-4 ml-4 relative">
                        <input type="text" name="s" class="text-white border-opacity-75 placeholder-opacity-75 lg:text-lg font-sans border-2 p-2 border-white bg-transparent w-full placeholder-white appearance-none" placeholder="Search Entertainment Daily" aria-label="Search">
                        <button class="absolute right-0 inset-y-0" type="submit" aria-label="Search">
                            <svg class="w-6 h-6 lg:m-0 lg:w-8 lg:h-8 opacity-75 fill-current"><use xlink:href="#icon-search"></use></svg>
                        </button>
                    </form>
                </div>
            </div>

            <div class="my-12 py-2 hidden md:block">
                <ul class="uppercase font-medium italic text-center flex justify-between">
                <li><a href="https://www.entertainmentdaily.co.uk/news/" class="hover:underline">News</a></li><li class="group"><a href="https://www.entertainmentdaily.co.uk/tv/" class="hover:underline ">TV</a><ul class="normal-case text-xs"><li><a href="https://www.entertainmentdaily.co.uk/good-morning-britain/" class="hover:underline">Good Morning Britain</a></li><li><a href="https://www.entertainmentdaily.co.uk/loose-women/" class="hover:underline">Loose Women</a></li><li><a href="https://www.entertainmentdaily.co.uk/the-chase/" class="hover:underline">The Chase</a></li><li><a href="https://www.entertainmentdaily.co.uk/this-morning/" class="hover:underline">This Morning</a></li><li><a href="https://www.entertainmentdaily.co.uk/saturday-night-takeaway/" class="hover:underline">Saturday Night Takeaway</a></li><li><a href="https://www.entertainmentdaily.co.uk/netflix/" class="hover:underline">Netflix</a></li></ul></li><li class="group"><a href="https://www.entertainmentdaily.co.uk/soaps/" class="hover:underline">Soaps</a><ul class="normal-case text-xs"><li><a href="https://www.entertainmentdaily.co.uk/coronation-street/" class="hover:underline">Coronation Street</a></li><li><a href="https://www.entertainmentdaily.co.uk/eastenders/" class="hover:underline">EastEnders</a></li><li><a href="https://www.entertainmentdaily.co.uk/emmerdale/" class="hover:underline">Emmerdale</a></li></ul></li><li><a href="https://www.entertainmentdaily.co.uk/royals/" class="hover:underline">Royals</a></li><li><a href="https://www.entertainmentdaily.co.uk/lifestyle/" class="hover:underline">Lifestyle</a></li>                </ul>
            </div>

            <div class="my-6 text-sm text-center uppercase">
                <a href="https://www.facebook.com/entertainmentdailyfix/" class="mx-3">
                    <svg class="w-8 h-8 inline fill-current my-3"><use xlink:href="#icon-facebook"></use></svg>
                </a>
                <div>
                    Connect with us
                </div>
            </div>

            <ul class="flex flex-col sm:flex-row font-bold text-center justify-around">
                <li class="group"><a href="https://www.entertainmentdaily.co.uk/about/" class="hover:underline">About Us</a><ul class=""><li><a href="https://www.entertainmentdaily.co.uk/news/meet-the-entertainment-daily-team/" class="hover:underline">Meet The Team</a></li><li><a href="https://www.entertainmentdaily.co.uk/news/entertainment-daily-editorial-policies/" class="hover:underline">Editorial Policies</a></li></ul></li><li><a href="https://www.entertainmentdaily.co.uk/cookies/" class="hover:underline js-show-cmp">Cookies Policy</a></li><li><a href="#" class="hover:underline js-show-cmp">Consent Settings</a></li><li><a href="https://www.entertainmentdaily.co.uk/privacy/" class="hover:underline">Privacy</a></li>            </ul>

            <div class="mt-6 text-xs text-center text-opacity-75">
                © 2021 <a href="/" class="underline">www.entertainmentdaily.co.uk</a>. All rights reserved.<br>
                Operated by Digitalbox Publishing Ltd.<br>
                Digitalbox Publishing Ltd. Co Reg No. 09909897
            </div>

        </div>
        <div id="ad-premium"></div>
    </footer>
</div>

</body>
</html>
