<!doctype html>
<html lang="en-GB">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
    <meta name="theme-color" content="#d60b52">

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO Premium plugin v17.2 (Yoast SEO v19.7.1) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Miles Jupp in SAS Rogue Heroes: Who is the Maj Knox actor?</title>
	<meta name="description" content="Everything we know about the talented actor and comedian, Miles Jupp, who plays Maj Knox in SAS Rogue Heroes on BBC One." />
	<link rel="canonical" href="https://www.entertainmentdaily.co.uk/tv/miles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown/" />
	<meta property="og:locale" content="en_GB" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Miles Jupp in SAS Rogue Heroes: Who is the Maj Knox actor and what is he famous for?" />
	<meta property="og:description" content="Everything we know about the talented actor and comedian, Miles Jupp, who plays Maj Knox in SAS Rogue Heroes on BBC One." />
	<meta property="og:url" content="https://www.entertainmentdaily.co.uk/tv/miles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown/" />
	<meta property="og:site_name" content="Entertainment Daily" />
	<meta property="article:publisher" content="https://www.facebook.com/entertainmentdailyfix/" />
	<meta property="article:published_time" content="2022-11-06T20:02:49+00:00" />
	<meta property="article:modified_time" content="2022-11-04T12:31:40+00:00" />
	<meta property="og:image" content="https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp.jpg" />
	<meta property="og:image:width" content="1500" />
	<meta property="og:image:height" content="784" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Aaliyah Ashfield" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@AaliyahAshfield" />
	<meta name="twitter:site" content="@EntDailyUK" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Aaliyah Ashfield" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="6 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<meta property="og:video" content="https://www.youtube.com/embed/gTWqFccBsgg" />
	<meta property="og:video:type" content="text/html" />
	<meta property="og:video:duration" content="62" />
	<meta property="og:video:width" content="480" />
	<meta property="og:video:height" content="270" />
	<meta property="ya:ovs:adult" content="false" />
	<meta property="ya:ovs:upload_date" content="2022-11-06T20:02:49+00:00" />
	<meta property="ya:ovs:allow_embed" content="true" />
	<!-- / Yoast SEO Premium plugin. -->


<style id='wp-parsely-recommendations-style-inline-css'>
.parsely-recommendations-list-title{font-size:1.2em}.parsely-recommendations-list{list-style:none;padding:unset}.parsely-recommendations-cardbody{overflow:hidden;padding:.8em;text-overflow:ellipsis;white-space:nowrap}.parsely-recommendations-cardmedia{padding:.8em .8em 0}

</style>
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='ed-style-css'  href='https://www.entertainmentdaily.co.uk/wp-content/themes/ed/style.css?ver=1.1' media='all' />
<script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"NewsArticle","headline":"Miles Jupp in SAS Rogue Heroes: Who is the Maj Knox actor and what is he famous for?","url":"http:\/\/www.entertainmentdaily.co.uk\/tv\/miles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown\/","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.entertainmentdaily.co.uk\/tv\/miles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown\/"},"thumbnailUrl":"https:\/\/cdn.entertainmentdaily.com\/2022\/11\/02153107\/Miles-Jupp.jpg","image":{"@type":"ImageObject","url":"https:\/\/cdn.entertainmentdaily.com\/2022\/11\/02153107\/Miles-Jupp.jpg"},"articleSection":"TV","author":[{"@type":"Person","name":"Aaliyah Ashfield"}],"creator":["Aaliyah Ashfield"],"publisher":{"@type":"Organization","name":"Entertainment Daily","logo":"https:\/\/cdn.entertainmentdaily.com\/2021\/01\/25101916\/cropped-logo-512.png"},"keywords":["bbc one","miles jupp","sas rogue heroes"],"dateCreated":"2022-11-06T20:02:49Z","datePublished":"2022-11-06T20:02:49Z","dateModified":"2022-11-06T20:02:49Z"}</script><link rel="icon" href="https://cdn.entertainmentdaily.com/2021/01/25101916/cropped-logo-512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://cdn.entertainmentdaily.com/2021/01/25101916/cropped-logo-512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://cdn.entertainmentdaily.com/2021/01/25101916/cropped-logo-512-180x180.png" />
<meta name="msapplication-TileImage" content="https://cdn.entertainmentdaily.com/2021/01/25101916/cropped-logo-512-270x270.png" />

    <link href="https://fonts.gstatic.com" rel="preconnect" crossorigin>
    <style id="" media="all">@font-face {
  font-family: 'Montserrat';
  font-style: italic;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/montserrat/v25/JTUFjIg1_i6t8kCHKm459Wx7xQYXK0vOoz6jq6R9WXh0ow.ttf) format('truetype');
}
@font-face {
  font-family: 'Montserrat';
  font-style: italic;
  font-weight: 600;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/montserrat/v25/JTUFjIg1_i6t8kCHKm459Wx7xQYXK0vOoz6jq3p6WXh0ow.ttf) format('truetype');
}
@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/montserrat/v25/JTUHjIg1_i6t8kCHKm4532VJOt5-QNFgpCtr6Hw5aX8.ttf) format('truetype');
}
@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 500;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/montserrat/v25/JTUHjIg1_i6t8kCHKm4532VJOt5-QNFgpCtZ6Hw5aX8.ttf) format('truetype');
}
@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 600;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/montserrat/v25/JTUHjIg1_i6t8kCHKm4532VJOt5-QNFgpCu173w5aX8.ttf) format('truetype');
}
</style>

    <script>dataLayer = [{'gtm.start': new Date().getTime(), event: 'gtm.js'}]; ED = {q:[]}</script>

    <script>!function(){var n=document.createElement("script"),e=document.getElementsByTagName("script")[0],t="https://quantcast.mgr.consensu.org".concat("/choice/","EDqRupKXQvznL","/","entertainmentdaily.co.uk","/choice.js"),a=0;function o(){var n,o="__tcfapiLocator",a=[],i=window;for(;i;){try{if(i.frames[o]){n=i;break}}catch(n){}if(i===window.top)break;i=i.parent}n||(!function n(){var e,t=i.document,a=!!i.frames[o];return a||(t.body?((e=t.createElement("iframe")).style.cssText="display:none",e.name=o,t.body.appendChild(e)):setTimeout(n,5)),!a}(),i.__tcfapi=function(){var n,e,t=arguments;if(!t.length)return a;"setGdprApplies"===t[0]?3<t.length&&2===t[2]&&"boolean"==typeof t[3]&&(n=t[3],"function"==typeof t[2]&&t[2]("set",!0)):"ping"===t[0]?(e={gdprApplies:n,cmpLoaded:!1,cmpStatus:"stub"},"function"==typeof t[2]&&t[2](e)):a.push(t)},i.addEventListener("message",function(a){var o="string"==typeof a.data,n={};try{n=o?JSON.parse(a.data):a.data}catch(n){}var i=n.__tcfapiCall;i&&window.__tcfapi(i.command,i.version,function(n,e){var t={__tcfapiReturn:{returnValue:n,success:e,callId:i.callId}};o&&(t=JSON.stringify(t)),a.source.postMessage(t,"*")},i.parameter)},!1))}n.async=!0,n.type="text/javascript",n.src=t,e.parentNode.insertBefore(n,e),"undefined"!=typeof module?module.exports=o:o();var i,s=function(){var n=arguments;typeof window.__uspapi!==s&&setTimeout(function(){void 0!==window.__uspapi&&window.__uspapi.apply(window.__uspapi,n)},500)};void 0===window.__uspapi&&(window.__uspapi=s,i=setInterval(function(){a++,window.__uspapi===s&&a<3?console.warn("USP is not accessible"):clearInterval(i)},6e3))}(),document.addEventListener("click",function(n){try{-1<n.target.className.indexOf("js-show-cmp")&&(n.preventDefault(),window.__tcfapi("displayConsentUi",2,function(){}))}catch(n){}},{capture:!0}),function(){(0,window.__tcfapi)("addEventListener",2,function(t,n){n&&("tcloaded"!==t.eventStatus&&"useractioncomplete"!==t.eventStatus||window.__tcfapi("getNonIABVendorConsents",2,function(n,e){e&&(window.dataLayer=window.dataLayer||[],window.dataLayer.push({event:"__cmpConsents",__cmpConsents:a(t,n)}))}))});function t(e){return","+Object.keys(e).filter(function(n){return e[n]}).join(",")+","}var a=function(n,e){return{iabVendorConsentIds:t(n.vendor.consents),nonIABVendorConsentIds:t(e.nonIabVendorConsents)}}}();;document.addEventListener("click",function(e){var t=e.target;t&&"nav-toggle"===t.id&&(t.setAttribute("aria-expanded","false"===t.getAttribute("aria-expanded")?"true":"false"),document.getElementById("nav-menu").classList.toggle("hidden"))});</script>

    <script src="https://www.entertainmentdaily.co.uk/wp-content/themes/ed/js/lazysizes.b80e49.js" async></script>

                    <script>window.gas = window.gas || {q:[]}</script>
                    <script src="https://gas.digitalbox.workers.dev/gas.js" async></script>
                            <script src="https://stacks.digitalbox.workers.dev/ed.js" async></script>
            
            <script>
            dataLayer.push({"author":"Aaliyah Ashfield","category":"TV","slug":"miles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown","published_at":"202211062002","page_type":"post"});
            ED.post = {"id":877421,"author":"Aaliyah Ashfield","slug":"miles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown","tags":["BBC One","Miles Jupp","SAS Rogue Heroes"],"categories":["TV"]};
        </script>
    
        <script src="https://www.googletagmanager.com/gtm.js?id=GTM-NV5NXDR" async></script>

    </head>

<body>
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg>

<div style="display:none;visibility:hidden;">
    <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><symbol viewBox="0 0 160 160" id="icon-facebook"><path d="M129.712.096q12.487 0 21.246 8.946 8.76 8.946 8.76 21.06v99.893q0 12.3-8.76 21.06-8.76 8.759-21.246 8.945H110.33V97.94h20.687l2.982-24.042h-23.67V58.429q0-5.777 2.424-8.572 2.422-2.796 9.504-2.982l12.673-.187V25.256q-6.522-.932-18.636-.932-13.978 0-22.55 8.2-8.574 8.2-8.387 23.669v17.705H64.483v24.041h20.874V160H30.005q-12.486 0-21.246-8.946Q0 142.11 0 129.994V30.103q0-12.3 8.76-21.06Q17.518.282 30.004.096h99.707z"/></symbol><symbol viewBox="0 0 186 115" id="icon-logo"><path d="M64.2 50.9H30.1L27.7 68h40.7l-2.6 17.5H4.9L16.7 1.6h60.9l-2.4 17.5H34.5L32.3 35h34.1zm40.5 34.6H72.4L84.1 1.6h32.3c24.4 0 38.7 15.4 38.7 36.5 0 26.5-20.7 47.4-50.4 47.4M102 19.1L95.2 68h10.5c14.9 0 28.4-10.6 28.4-28.1 0-13.7-9.2-20.8-21.5-20.8H102zM166 63c6 0 10.3 4.6 10.3 10.5 0 7.3-6.6 13.1-13.7 13.1-6 0-10.2-4.5-10.2-10.3.1-7.3 6.4-13.3 13.6-13.3m7.6-7.4h-13.1l2.7-53.9H186l-12.4 53.9zM11.1 104.9H5l-.4 3.5h7.2l-.4 2.4h-10l2-13.9h10l-.4 2.5H5.8l-.4 3.2h6.1zm4.1 5.9h-2.8l1.4-9.7h1.7l.2 1.4h.2c.9-1.1 1.8-1.6 3.4-1.6 2.5 0 3.8 1.7 3.4 4.3l-.8 5.7h-2.8l.8-5.4c.2-1.2-.4-2.1-1.7-2.1s-2.1 1-2.3 2l-.7 5.4zm10.1-9.7l.4-3h2.8l-.4 3h2.4l-.3 2.2h-2.4l-.6 4.4c-.1.7.2 1.1.9 1.1.6 0 1.1-.3 1.1-.3l.5 1.9c-.4.3-1.5.8-2.6.8-2.3 0-3-1.4-2.7-3.4l.6-4.5h-1.7l.3-2.2h1.7z"/><path d="M38.5 109.9s-1.3 1.2-3.8 1.2c-2.9 0-4.6-1.9-4.6-4.4 0-3.3 2.4-5.8 5.6-5.8 2.5 0 3.9 1.6 3.9 4.1 0 .8-.2 1.6-.2 1.6h-6.7c-.1 1.7.8 2.4 2.4 2.4 1.5 0 2.6-.8 2.6-.8l.8 1.7zm-5.4-5.1H37c0-1.2-.5-1.9-1.6-1.9s-1.9.6-2.3 1.9m13.2-1.4h-.5c-1.3 0-2.4.9-2.6 2.4l-.7 5h-2.8l1.4-9.7h1.7l.2 1.4h.1c.7-1 1.6-1.4 2.9-1.4h.5l-.2 2.3zm2.9-2.3l.4-3h2.8l-.4 3h2.4l-.3 2.2h-2.4l-.6 4.4c-.1.7.2 1.1.9 1.1.6 0 1.1-.3 1.1-.3l.5 1.9c-.4.3-1.5.8-2.6.8-2.3 0-3-1.4-2.7-3.4l.6-4.5h-1.7l.3-2.2h1.7z"/><path d="M62.4 102.4l.6-1.3h1.8l-1.4 9.7h-1.8l-.3-1.3h-.1s-1 1.6-3.4 1.6c-2.3 0-3.9-1.7-3.9-4.3 0-3.4 2.5-5.9 5.3-5.9 2.4 0 3 1.6 3 1.6h.2zm-2.8.7c-1.5 0-2.7 1.4-2.7 3.2 0 1.4.7 2.4 1.9 2.4 1.6 0 2.8-1.3 2.8-3.3.1-1.4-.7-2.3-2-2.3m6.8-2h2.8l-1.4 9.7H65l1.4-9.7zm.2-2.9c0-1 .9-1.8 1.9-1.8.8 0 1.4.6 1.4 1.4 0 1-.9 1.8-1.9 1.8-.8 0-1.4-.6-1.4-1.4m5.5 12.6h-2.8l1.4-9.7h1.7l.2 1.4h.2c.9-1.1 1.8-1.6 3.4-1.6 2.5 0 3.8 1.7 3.4 4.3l-.8 5.7H76l.8-5.4c.2-1.2-.4-2.1-1.7-2.1s-2.1 1-2.3 2l-.7 5.4zm17.2 0h-2.8l.8-5.5c.2-1.1-.4-2-1.7-2s-2.1.9-2.2 1.9l-.8 5.7h-2.8l1.4-9.7h1.7l.2 1.4h.2c.8-1 1.8-1.6 3.3-1.6 1.6 0 2.7.6 3.2 1.7h.1c.8-1 1.8-1.7 3.4-1.7 2.5 0 3.8 1.7 3.4 4.3l-.8 5.7h-2.8l.8-5.4c.2-1.2-.4-2.1-1.6-2.1-1.3 0-2.1 1-2.2 2l-.8 5.3zm16.5-.9s-1.3 1.2-3.8 1.2c-2.9 0-4.6-1.9-4.6-4.4 0-3.3 2.4-5.8 5.6-5.8 2.5 0 3.9 1.6 3.9 4.1 0 .8-.2 1.6-.2 1.6H100c-.1 1.7.8 2.4 2.4 2.4 1.5 0 2.6-.8 2.6-.8l.8 1.7zm-5.4-5.1h3.9c0-1.2-.5-1.9-1.6-1.9s-1.9.6-2.3 1.9m9.4 6H107l1.4-9.7h1.7l.2 1.4h.2c.9-1.1 1.8-1.6 3.4-1.6 2.5 0 3.8 1.7 3.4 4.3l-.8 5.7h-2.8l.8-5.4c.2-1.2-.4-2.1-1.7-2.1s-2.1 1-2.2 2l-.8 5.4z"/><path d="M119.4 101.1l.4-3h2.8l-.4 3h2.4l-.3 2.2h-2.4l-.6 4.4c-.1.7.2 1.1.9 1.1.6 0 1.1-.3 1.1-.3l.5 1.9c-.4.3-1.5.8-2.6.8-2.3 0-3-1.4-2.7-3.4l.6-4.5h-1.7l.3-2.2h1.7zm14.9 9.7h-5.1l1.9-13.9h5.1c4 0 6.4 2.5 6.4 6 0 4.6-3.5 7.9-8.3 7.9m-.7-11.4l-1.3 9h2.1c2.8 0 5.2-1.9 5.2-5.2 0-2.5-1.7-3.8-4-3.8h-2z"/><path d="M151 102.4l.6-1.3h1.8l-1.4 9.7h-1.8l-.3-1.3h-.1s-1 1.6-3.4 1.6c-2.3 0-3.9-1.7-3.9-4.3 0-3.4 2.5-5.9 5.3-5.9 2.4 0 3 1.6 3 1.6h.2zm-2.9.7c-1.5 0-2.7 1.4-2.7 3.2 0 1.4.7 2.4 1.9 2.4 1.6 0 2.8-1.3 2.8-3.3.1-1.4-.7-2.3-2-2.3m6.4-2h2.8l-1.4 9.7h-2.8l1.4-9.7zm.2-2.9c0-1 .9-1.8 1.9-1.8.8 0 1.4.6 1.4 1.4 0 1-.9 1.8-1.9 1.8-.9 0-1.4-.6-1.4-1.4m4.7-1.4h2.8l-2 14h-2.8zm12.5 4.3l-1.3 9.2c-.4 2.7-2.3 4.7-5.6 4.7-2 0-3.2-.9-3.7-1.5l1.6-1.7c.3.4 1 1 2.4 1 1.5 0 2.4-.9 2.6-2.4l.1-.5c-.6.5-1.6 1.1-2.9 1.1-2.6 0-3.8-1.7-3.5-4.3l.8-5.6h2.8l-.8 5.4c-.2 1.3.3 2.2 1.6 2.2s2.2-.9 2.4-1.9l.8-5.7h2.7z"/></symbol><symbol viewBox="0 0 48 48" id="icon-search"><path d="M31 28h-2v-1c2-2 3-5 3-8a13 13 0 1 0-5 10h1v2l10 10 3-3-10-10zm-12 0a9 9 0 1 1 0-18 9 9 0 0 1 0 18z"/></symbol></svg></div>

<div id="wrapper">

	<header class="text-white">

        <div class="bg-brand py-1 relative">

            <div class="container flex justify-between">

                <a href="/" aria-label="Home">
                    <svg class="w-16 h-12 md:w-24 md:h-16 lg:w-32 lg:h-24 fill-current"><use xlink:href="#icon-logo"></use></svg>
                </a>

                <div class="absolute -mb-4 bottom-0 z-10 hidden lg:block">
                    <a class="sr-only focus:not-sr-only text-brand bg-white block whitespace-no-wrap" href="#content">Skip to content</a>
                </div>

                <div class="flex-grow hidden sm:block px-6 md:mt-2 lg:mt-6">
                    <div class="text-white text-opacity-75 italic whitespace-no-wrap md:text-lg">
                        All the latest TV, showbiz &amp; lifestyle                    </div>
                    <div class="text-white text-opacity-75 text-sm">
                        Sunday, November 6, 2022                    </div>
                </div>

                <button id="nav-toggle" class="px-4 text-2xl lg:hidden" aria-controls="nav-menu" aria-expanded="false" aria-label="Menu">
                    ☰
                </button>

            </div>

        </div>

		<nav id="nav-menu" class="hidden bg-brand-dark text-right leading-relaxed lg:block">

            <div class="container relative">

                <div class="absolute z-50 right-0 px-4 py-2 bg-brand md:px-12 lg:p-0 lg:block lg:static lg:bg-brand-dark lg:w-auto">
                    <ul class="uppercase font-medium underline lg:no-underline lg:flex lg:justify-between">
                    <li><a href="https://www.entertainmentdaily.co.uk/news/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">News </a></li><li class="group"><a href="https://www.entertainmentdaily.co.uk/tv/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative bg-brand">TV <span class="text-xs invisible lg:visible">&#9660; </span></a><ul class="bg-brand-dark normal-case p-2 z-50 no-underline lg:hidden lg:absolute lg:text-left group-hover:block"><li><a href="https://www.entertainmentdaily.co.uk/tv-spoilers/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">TV Spoilers </a></li><li><a href="https://www.entertainmentdaily.co.uk/good-morning-britain/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Good Morning Britain </a></li><li><a href="https://www.entertainmentdaily.co.uk/loose-women/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Loose Women </a></li><li><a href="https://www.entertainmentdaily.co.uk/the-chase/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">The Chase </a></li><li><a href="https://www.entertainmentdaily.co.uk/this-morning/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">This Morning </a></li><li><a href="https://www.entertainmentdaily.co.uk/saturday-night-takeaway/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Saturday Night Takeaway </a></li><li><a href="https://www.entertainmentdaily.co.uk/netflix/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Netflix </a></li></ul></li><li class="group"><a href="https://www.entertainmentdaily.co.uk/soaps/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Soaps <span class="text-xs invisible lg:visible">&#9660; </span></a><ul class="bg-brand-dark normal-case p-2 z-50 no-underline lg:hidden lg:absolute lg:text-left group-hover:block"><li><a href="https://www.entertainmentdaily.co.uk/eastenders/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">EastEnders </a></li><li><a href="https://www.entertainmentdaily.co.uk/coronation-street/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Coronation Street </a></li><li><a href="https://www.entertainmentdaily.co.uk/emmerdale/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Emmerdale </a></li></ul></li><li><a href="https://www.entertainmentdaily.co.uk/royals/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Royals </a></li><li><a href="https://www.entertainmentdaily.co.uk/true-crime/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">True Crime </a></li><li><a href="https://www.entertainmentdaily.co.uk/national-lottery/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Lottery </a></li><li><a href="https://www.entertainmentdaily.co.uk/lifestyle/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Lifestyle </a></li><li class="group"><a href="https://www.entertainmentdaily.co.uk/trending/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Trending <span class="text-xs invisible lg:visible">&#9660; </span></a><ul class="bg-brand-dark normal-case p-2 z-50 no-underline lg:hidden lg:absolute lg:text-left group-hover:block"><li><a href="https://www.entertainmentdaily.co.uk/strictly-come-dancing/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Strictly Come Dancing </a></li><li><a href="https://www.entertainmentdaily.co.uk/made-in-chelsea/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">Made in Chelsea </a></li><li><a href="https://www.entertainmentdaily.co.uk/im-a-celebrity/" class="hover:bg-brand block lg:px-4 lg:py-1 lg:relative">I&#8217;m A Celebrity&#8230; </a></li></ul></li>                    </ul>
                    <a href="https://www.facebook.com/entertainmentdailyfix/" class="lg:absolute lg:bottom-0 lg:right-0 lg:mr-12 lg:mb-16 lg:mx-3">
                        <svg class="w-8 h-8 fill-current inline-block my-3"><use xlink:href="#icon-facebook"></use></svg>
                    </a>
                </div>

            </div>

        </nav>

	</header>

    <div id="content" class="container py-1">

    <main>

        <div class="lg:flex lg:min-h-screen">

            <div class="flex-shrink">

                <div class="flex sm:inline-flex lg:mb-2 justify-between uppercase mb-1 lg:mt-1 text-white text-right">
                    <a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.entertainmentdaily.co.uk%2Ftv%2Fmiles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown%2F"
                       class="share-fb flex-1" target="_blank" aria-label="Share on Facebook" tabindex="-1">Share</a>
                    <a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.entertainmentdaily.co.uk%2Ftv%2Fmiles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown%2F&text=Miles+Jupp+in+SAS+Rogue+Heroes%3A+Who+is+the+Maj+Knox+actor+and+what+is+he+famous+for%3F"
                       class="share-twitter flex-1" target="_blank" aria-label="Share on Twitter"
                       tabindex="-1">Share</a>
                    <a href="https://wa.me/?text=https%3A%2F%2Fwww.entertainmentdaily.co.uk%2Ftv%2Fmiles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown%2F+Miles+Jupp+in+SAS+Rogue+Heroes%3A+Who+is+the+Maj+Knox+actor+and+what+is+he+famous+for%3F"
                       class="share-whatsapp flex-1 sm:hidden" target="_blank" aria-label="Share on WhatsApp"
                       tabindex="-1">Share</a>
                </div>

                <article class="lg:mr-20 js-article">
                                            <div class="force-aspect placeholder"
                                                            style="background: url(https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-180x94.jpg) no-repeat; background-size: cover;"
                                                    >
                            <img class="w-full absolute inset-0 lazyload" alt="Miles Jupp smiling on the red carpet and wearing army uniform in SAS Rogue Heroes" sizes="(min-width: 1024px) 660px, 100vw" data-src="https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp.jpg 1500w, https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-400x209.jpg 400w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-742x388.jpg" alt="Miles Jupp smiling on the red carpet and wearing army uniform in SAS Rogue Heroes" class="w-full absolute inset-0 lazyload"></noscript>                        </div>
                    
                                            <a class="px-1 lg:mt-2 inline-block bg-brand text-white uppercase text-xs"
                           href="https://www.entertainmentdaily.co.uk/tv/">TV</a>
                    
                    <h1 class="text-brand text-2xl font-semibold leading-none lg:text-3xl">
                        Miles Jupp in SAS Rogue Heroes: Who is the Maj Knox actor and what is he famous for?                    </h1>

                    <h2 class="text-gray-800 font-medium leading-tight text-lg my-1 lg:mb-3">
                        Fans may recognise Miles Jupp from The Crown                    </h2>

                    <div class="text-xs clearfix leading-tight mb-2 lg:leading-relaxed lg:float-left lg:w-32">
                                                    <img src="https://cdn.entertainmentdaily.com/2022/03/25142041/Image-64x64.jpeg" alt=""
                                 class="rounded-full border-2 border-gray-400 w-8 h-8 mr-2 float-left lg:w-16 lg:h-16 lg:float-none">
                                                <div class="h-8 flex flex-col justify-center lg:block">
                            <div class="text-brand">
                                <span class="lg:hidden">By</span> <a
                                        href="https://www.entertainmentdaily.co.uk/author/aaliyah-ashfield/">Aaliyah Ashfield</a>
                            </div>
                            <div>
                                <time datetime="2022-11-06T20:02:49+00:00"
                                      aria-label="Published at">6 Nov 2022, 20:02</time>
                                                                    <span class="lg:hidden">|</span>
                                    <span class="lg:block">Updated:</span>
                                    <time datetime="2022-11-04T12:31:40+00:00"
                                          aria-label="Updated at">4 Nov 2022, 12:31</time>
                                                            </div>

                                                            <div class="hidden text-xs lg:block">
                                    Tags:
                                                                            <a href="/bbc-one/"
                                           class="text-brand">BBC One</a>,                                                                            <a href="/miles-jupp/"
                                           class="text-brand">Miles Jupp</a>,                                                                            <a href="/sas-rogue-heroes/"
                                           class="text-brand">SAS Rogue Heroes</a>                                                                    </div>
                                                    </div>

                    </div>

                    <div class="drop-cap rich-text mx-auto sm:max-w-md md:max-w-lg lg:ml-40 lg:mt-3 js-article-body">
                        <p>Miles Jupp may have surprised some viewers with his appearance in the BBC One series SAS Rogue Heroes.</p>
<p>The actor plays Maj Knox in the show, based on the real-life military officer.</p>
<p>But eagle-eyed TV fans may have recognised the performer from starring in many other popular TV shows like The Thick of It opposite <a href="https://www.entertainmentdaily.co.uk/peter-capaldi">Peter Capaldi</a>, The Crown, and Trigger Point.</p>
<p>But who is Miles Jupp, how old is he, and what is he doing now?</p>

<figure>
	<div class="relative bg-gray-200" style="padding-top: 136%">
		<img class="w-full absolute inset-0 lazyload" data-src="https://cdn.entertainmentdaily.com/2022/11/02153412/spl1458040_043-400x544.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/02153412/spl1458040_043-800x1087.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/02153412/spl1458040_043-768x1044.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/02153412/spl1458040_043-400x544.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/02153412/spl1458040_043-scaled.jpg 1883w" sizes="(min-width: 500px) 500px, 100vw" alt="Miles Jupp wearing a tuxedo">
		<noscript>
			<img class="w-full absolute inset-0" src="https://cdn.entertainmentdaily.com/2022/11/02153412/spl1458040_043-400x544.jpg" srcset="https://cdn.entertainmentdaily.com/2022/11/02153412/spl1458040_043-800x1087.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/02153412/spl1458040_043-768x1044.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/02153412/spl1458040_043-400x544.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/02153412/spl1458040_043-scaled.jpg 1883w" alt="Miles Jupp wearing a tuxedo">		
		</noscript>
	</div>
<figcaption class='text-sm italic leading-tight mt-1'>Miles Jupp is known for being a comedian (Credit: Splash News)</figcaption>
</figure>

<h3>Who plays May Knox is SAS Rogue Heroes?</h3>
<p>Miles Jupp plays Sir Alfred Knox &#8211; aka Major Knox &#8211; in the BBC One series <a href="https://www.entertainmentdaily.co.uk/sas-rogue-heroes/">SAS Rogue Heroes</a>.</p>
<p>Maj Knox was a real-life military officer in both World War I and World War II.</p>
<p>In the series, we see Maj Knox during his service in the Middle East in 1941, where he meets the radical <a href="https://www.entertainmentdaily.co.uk/tv/sas-rogue-heroes-what-happened-to-david-stirling/">David Stirling</a>.</p>
<p>Maj Knox didn&#8217;t have a vital role in the SAS, but he is a well-remembered war hero and he&#8217;s known for his great efforts in the war.</p>
<p>Sadly, the military officer died on March 09 1964.</p>
<h3>Who is Miles Jupp?</h3>
<p><a href="https://www.entertainmentdaily.co.uk/miles-jupp">Miles Jupp</a> is a British actor and comedian who started performing stand-up comedy in 2000.</p>
<p>He went on to win both So You Think You&#8217;re Funny? and Leicester Mercury Comedian of the Year.</p>
<p>Miles subsequently earned a regular spot on BBC Scotland&#8217;s Live Floor Show where he played an eccentric, foul-mouthed comedian.</p>
<p>In 2002, he launched his career as an actor when he played the role of Archie in the children&#8217;s series Balamory.</p>
<p>Now, Miles has popped up everywhere in a range of popular TV shows including The Thick of It, Rev, and <a href="https://www.entertainmentdaily.co.uk/outnumbered">Outnumbered</a>.</p>
<p>Miles has also contributed to many BBC Radio 4 shows, including The Vote Now Show and Loose Ends.</p>

<figure>
	<div class="relative bg-gray-200" style="padding-top: 66.5%">
		<img class="w-full absolute inset-0 lazyload" data-src="https://cdn.entertainmentdaily.com/2022/11/02153540/391001-400x266.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/02153540/391001-800x532.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/02153540/391001-768x511.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/02153540/391001-400x266.jpg 400w" sizes="(min-width: 500px) 500px, 100vw" alt="Miles Jupp driving a jeep in SAS Rogue Heroes">
		<noscript>
			<img class="w-full absolute inset-0" src="https://cdn.entertainmentdaily.com/2022/11/02153540/391001-400x266.jpg" srcset="https://cdn.entertainmentdaily.com/2022/11/02153540/391001-800x532.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/02153540/391001-768x511.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/02153540/391001-400x266.jpg 400w" alt="Miles Jupp driving a jeep in SAS Rogue Heroes">		
		</noscript>
	</div>
<figcaption class='text-sm italic leading-tight mt-1'>Miles Jupp plays Maj Knox in SAS Rogue Heroes (Credit: BBC One)</figcaption>
</figure>

<h3>What is Miles Jupp doing now?</h3>
<p>Miles Jupp is currently taking to the stage and performing in the crime comedy The Lavender Hill Mob, which is touring the UK in November, January, and February.</p>
<p>The comedian is starring alongside Justin Edwards, who he also co-starred with on In and Out of the Kitchen on Radio 4.</p>
<p>Talking about the play, Miles Jupp said: &#8220;I loved the Lavender Hill Mob when I first saw it.</p>
<p>&#8220;I love Phil Porter&#8217;s ingenious adaptation of it, and I&#8217;ve loved every Jeremy Sams production I&#8217;ve seen.</p>
<p>&#8220;I love working with Justin Edwards, I absolutely love being part of an ensemble onstage, and I&#8217;ve loved doing nearly every play I&#8217;ve been in.&#8221;</p>

<figure>
	<div class="relative bg-gray-200" style="padding-top: 56.25%">
		<img class="w-full absolute inset-0 lazyload" data-src="https://cdn.entertainmentdaily.com/2022/11/04115757/388301-400x225.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/04115757/388301-800x450.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/04115757/388301-768x432.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/04115757/388301-400x225.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/04115757/388301.jpg 1920w" sizes="(min-width: 500px) 500px, 100vw" alt="Miles Jupp hosts Have I Got News For You?">
		<noscript>
			<img class="w-full absolute inset-0" src="https://cdn.entertainmentdaily.com/2022/11/04115757/388301-400x225.jpg" srcset="https://cdn.entertainmentdaily.com/2022/11/04115757/388301-800x450.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/04115757/388301-768x432.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/04115757/388301-400x225.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/04115757/388301.jpg 1920w" alt="Miles Jupp hosts Have I Got News For You?">		
		</noscript>
	</div>
<figcaption class='text-sm italic leading-tight mt-1'>Miles Jupp hosting Have I Got News For You? (Credit: BBC One)</figcaption>
</figure>

<h3>What else has SAS Rogue Heroes star Miles Jupp been in?</h3>
<p>Miles Jupp has appeared in a variety of TV shows including Comedy Lab and Father Brown.</p>
<p>One of Miles&#8217; most notable appearances was in the popular TV series <a href="https://www.entertainmentdaily.co.uk/the-crown/">The Crown</a>.</p>
<p>Miles took on the role of Humphrey in the Netflix series, who features in the second series.</p>
<p>Miles also played Basil in ITV comedy drama <a href="https://www.entertainmentdaily.co.uk/the-durrells/">The Durrells</a>.</p>
<p>Basil was Louisa&#8217;s blundering and nosy second cousin who always seemed to put his foot in it.</p>
<p>The actor starred alongside <a href="https://www.entertainmentdaily.co.uk/keeley-hawes/">Keeley Hawes</a>, Josh O&#8217;Connor and Callum Woodhouse.</p>
<p>Harry Potter fans may also recognise Miles from his role as a TV weatherman in Harry Potter and the Order of the Pheonix.</p>
<p>Miles has also starred in the well-known films Sherlock Holmes and Johnny English Reborn.</p>
<p>More recently, he starred as Shaun Hallett in the <a href="https://www.entertainmentdaily.co.uk/tv/professor-t-itv-series-two-cast-ben-miller-juliet-stevenson-emma-naomi/">cast of Professor T</a>, Simon Shenley in Trigger Point, and Marcus Asper in Grantchester.</p>

<figure>
	<div class="relative bg-gray-200" style="padding-top: 131.25%">
		<img class="w-full absolute inset-0 lazyload" data-src="https://cdn.entertainmentdaily.com/2022/11/02153841/spl1597019_004-400x525.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/02153841/spl1597019_004-800x1050.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/02153841/spl1597019_004-768x1008.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/02153841/spl1597019_004-400x525.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/02153841/spl1597019_004-scaled.jpg 1950w" sizes="(min-width: 500px) 500px, 100vw" alt="Miles Jupp posing on the red carpet">
		<noscript>
			<img class="w-full absolute inset-0" src="https://cdn.entertainmentdaily.com/2022/11/02153841/spl1597019_004-400x525.jpg" srcset="https://cdn.entertainmentdaily.com/2022/11/02153841/spl1597019_004-800x1050.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/02153841/spl1597019_004-768x1008.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/02153841/spl1597019_004-400x525.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/02153841/spl1597019_004-scaled.jpg 1950w" alt="Miles Jupp posing on the red carpet">		
		</noscript>
	</div>
<figcaption class='text-sm italic leading-tight mt-1'>Miles Jupp is married with five children (Credit: Splash News)</figcaption>
</figure>

<h3>Is Miles Jupp married? How many children does he have?</h3>
<p>Miles is married to a woman called Rachel whom he met while studying in Edinburgh.</p>
<p>The couple raise their five children in Monmouthshire, Wales.</p>
<p>Miles has previously admitted that his family miss living in London.</p>
<p>He said: &#8220;The children are at a really nice school now, but we do find ourselves missing Peckham.</p>
<p>&#8220;It was really mixed and fun, just some really interesting parents at the school.</p>
<p>&#8220;As indeed there are where we are now&#8230;</p>
<p>&#8220;But it was much more mixed.</p>
<p>&#8220;That was really good for the children, to have a less cosseted upbringing than I did.&#8221;</p>
<h3>How old is SAS Rogue Heroes star Miles Jupp?</h3>
<p>Miles Hugh Barrett Jupp was born on September 08 1979.</p>
<p>This means that he is currently 43 years old.</p>
<h3>Where is he from?</h3>
<p>Miles was born in Newcastle upon Tyne, England, but spent most of his childhood in London.</p>
<p>He is the son of a minister in the United Reformed Church.</p>
<p>Miles was educated at three independent schools &#8211; The Hall School in Hampstead, North London, St George&#8217;s School in Windsor, and Oakham School in Rutland.</p>
<p>He studied Divinity at the University of Edinburgh, before finding fame on stage.</p>

<figure>
	<div class="relative bg-gray-200" style="padding-top: 140.75%">
		<img class="w-full absolute inset-0 lazyload" data-src="https://cdn.entertainmentdaily.com/2022/11/02154022/SPL4133574_011-400x563.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/02154022/SPL4133574_011-800x1125.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/02154022/SPL4133574_011-768x1080.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/02154022/SPL4133574_011-400x563.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/02154022/SPL4133574_011-scaled.jpg 1820w" sizes="(min-width: 500px) 500px, 100vw" alt="Miles Jupp wearing a black jacket on the red carpet">
		<noscript>
			<img class="w-full absolute inset-0" src="https://cdn.entertainmentdaily.com/2022/11/02154022/SPL4133574_011-400x563.jpg" srcset="https://cdn.entertainmentdaily.com/2022/11/02154022/SPL4133574_011-800x1125.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/02154022/SPL4133574_011-768x1080.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/02154022/SPL4133574_011-400x563.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/02154022/SPL4133574_011-scaled.jpg 1820w" alt="Miles Jupp wearing a black jacket on the red carpet">		
		</noscript>
	</div>
<figcaption class='text-sm italic leading-tight mt-1'>Miles Jupp appeared in an episode of Trigger Point (Credit: Splash News)</figcaption>
</figure>

<h3>Is Miles Jupp in Trigger Point?</h3>
<p>Miles Jupp recently appeared in an episode of the ITV drama <a href="https://www.entertainmentdaily.co.uk/trigger-point/">Trigger Point</a> earlier this year.</p>
<p>The comedian played a radio presenter, Simon Henley, who was targeted by a bomber in an auditorium.</p>
<p>Miles&#8217; character Simon was hosting a debate show for the upcoming election, when the suspect left a package hidden among the broadcast equipment.</p>
<p>The bomb had two mobile phones strapped to it, which meant there would be one to arm it and another to trigger it.</p>
<p>But luckily, <a href="https://www.entertainmentdaily.co.uk/vicky-mcclure">Vicky McClure</a>&#8216;s character Lana made it in time to disarm the bomb.</p>
<p><strong>Read more: <a href="https://www.entertainmentdaily.co.uk/tv/sas-rogue-heroes-start-date-plot-cast-bbc-episodes/">SAS Rogue Heroes on BBC One: How many episodes is it, is it based on a book and start date</a></strong></p>
<p><iframe loading="lazy" title="YouTube video player" src="https://www.youtube.com/embed/gTWqFccBsgg" width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<h3>SAS Rogue Heroes airs on Sundays on BBC One at 9pm from October 30 2022.</h3>
<p><em><strong>Are you enjoying SAS Rogue Heroes so far? Leave us a comment on our <a href="https://www.facebook.com/entertainmentdailyfix">Facebook page @EntertainmentDailyFix</a> and let us know.</strong></em></p>
                    </div>

                    

	                
                    <div class="flex sm:inline-flex justify-between uppercase my-1 text-white text-right lg:ml-40">
                        <a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.entertainmentdaily.co.uk%2Ftv%2Fmiles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown%2F"
                           class="share-fb flex-1" target="_blank" aria-label="Share on Facebook">Share</a>
                        <a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.entertainmentdaily.co.uk%2Ftv%2Fmiles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown%2F&text=Miles+Jupp+in+SAS+Rogue+Heroes%3A+Who+is+the+Maj+Knox+actor+and+what+is+he+famous+for%3F"
                           class="share-twitter flex-1" target="_blank" aria-label="Share on Twitter">Share</a>
                        <a href="https://wa.me/?text=https%3A%2F%2Fwww.entertainmentdaily.co.uk%2Ftv%2Fmiles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown%2F+Miles+Jupp+in+SAS+Rogue+Heroes%3A+Who+is+the+Maj+Knox+actor+and+what+is+he+famous+for%3F"
                           class="share-whatsapp flex-1 sm:hidden" target="_blank" aria-label="Share on WhatsApp">Share</a>
                    </div>

                                            <div class="text-sm my-6 lg:ml-40">
                            <h3 class="italic uppercase">Related Topics</h3>
                            <div>
                                                                    <a href="/bbc-one/"
                                       class="bg-brand text-white px-1">BBC One</a>
                                                                    <a href="/miles-jupp/"
                                       class="bg-brand text-white px-1">Miles Jupp</a>
                                                                    <a href="/sas-rogue-heroes/"
                                       class="bg-brand text-white px-1">SAS Rogue Heroes</a>
                                                            </div>
                        </div>
                    
                </article>

                                <div class="my-6 py-2 bg-gray-200 border-t-2 border-brand text-sm leading-tight lg:mr-6">
                    <h3 class="px-3 italic uppercase">Trending Articles</h3>
                    <div class="flex flex-wrap text-brand mr-3">
                    
                        <div class="mt-2 w-1/2 sm:w-1/3">
                            <div class="ml-3">
                                                                    <div class="force-aspect mb-px">
                                        <a href="https://www.entertainmentdaily.co.uk/tv/strictly-results-viewers-sad-elimination-dancer-cries/" tabindex="-1">
                                            <img class="w-full absolute inset-0 lazyload" alt="Strictly couple in the dance off" sizes="(min-width: 1150px) 240px, (min-width: 640px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-742x388.png" data-srcset="https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-742x388.png 742w, https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-768x401.png 768w, https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-360x188.png 360w, https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-180x94.png 180w, https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-800x418.png 800w, https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-400x209.png 400w, https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit.png 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-742x388.png" alt="Strictly couple in the dance off" class="w-full absolute inset-0 lazyload"></noscript>                                        </a>
                                    </div>
                                                                <a href="https://www.entertainmentdaily.co.uk/tv/strictly-results-viewers-sad-elimination-dancer-cries/">
                                    Strictly results: Viewers reveal their &#8216;sadness&#8217; over elimination as &#8216;disappointed&#8217; pro dancer shares his upset                                </a>
                            </div>
                        </div>

                    
                        <div class="mt-2 w-1/2 sm:w-1/3">
                            <div class="ml-3">
                                                                    <div class="force-aspect mb-px">
                                        <a href="https://www.entertainmentdaily.co.uk/tv/im-a-celebrity-matt-hancock-main-motivation-revealed/" tabindex="-1">
                                            <img class="w-full absolute inset-0 lazyload" alt="Matt Hancock and his I&#039;m A Celebrity co-stars" sizes="(min-width: 1150px) 240px, (min-width: 640px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-742x388.png" data-srcset="https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-742x388.png 742w, https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-768x401.png 768w, https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-360x188.png 360w, https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-180x94.png 180w, https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-800x418.png 800w, https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-400x209.png 400w, https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1.png 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-742x388.png" alt="Matt Hancock and his I&#039;m A Celebrity co-stars" class="w-full absolute inset-0 lazyload"></noscript>                                        </a>
                                    </div>
                                                                <a href="https://www.entertainmentdaily.co.uk/tv/im-a-celebrity-matt-hancock-main-motivation-revealed/">
                                    I&#8217;m A Celebrity: Matt Hancock&#8217;s &#8216;main motivation&#8217; for taking part &#8216;revealed&#8217;                                </a>
                            </div>
                        </div>

                    
                        <div class="mt-2 w-1/2 sm:w-1/3">
                            <div class="ml-3">
                                                                    <div class="force-aspect mb-px">
                                        <a href="https://www.entertainmentdaily.co.uk/royals/prince-andrew-news-blindsided-king-charles-blow/" tabindex="-1">
                                            <img class="w-full absolute inset-0 lazyload" alt="Charles and Andrew looking annoyed" sizes="(min-width: 1150px) 240px, (min-width: 640px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/06115627/charles-andrew-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/06115627/charles-andrew-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2022/11/06115627/charles-andrew-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/06115627/charles-andrew-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2022/11/06115627/charles-andrew-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2022/11/06115627/charles-andrew-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/06115627/charles-andrew-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/06115627/charles-andrew.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/06115627/charles-andrew-742x388.jpg" alt="Charles and Andrew looking annoyed" class="w-full absolute inset-0 lazyload"></noscript>                                        </a>
                                    </div>
                                                                <a href="https://www.entertainmentdaily.co.uk/royals/prince-andrew-news-blindsided-king-charles-blow/">
                                    Prince Andrew news: Duke ‘tearful’ and ‘blindsided’ after King Charles delivered huge blow                                </a>
                            </div>
                        </div>

                    
                        <div class="mt-2 w-1/2 sm:w-1/3">
                            <div class="ml-3">
                                                                    <div class="force-aspect mb-px">
                                        <a href="https://www.entertainmentdaily.co.uk/tv/im-a-celebrity-fans-question-why-frankie-got-a-camera-as-her-luxury-item/" tabindex="-1">
                                            <img class="w-full absolute inset-0 lazyload" sizes="(min-width: 1150px) 240px, (min-width: 640px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2021/12/03223053/Im-A-Celebrity-Frankie-camera-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2021/12/03223053/Im-A-Celebrity-Frankie-camera-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2021/12/03223053/Im-A-Celebrity-Frankie-camera-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2021/12/03223053/Im-A-Celebrity-Frankie-camera-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2021/12/03223053/Im-A-Celebrity-Frankie-camera-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2021/12/03223053/Im-A-Celebrity-Frankie-camera-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2021/12/03223053/Im-A-Celebrity-Frankie-camera-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2021/12/03223053/Im-A-Celebrity-Frankie-camera.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2021/12/03223053/Im-A-Celebrity-Frankie-camera-742x388.jpg" alt="" class="w-full absolute inset-0 lazyload"></noscript>                                        </a>
                                    </div>
                                                                <a href="https://www.entertainmentdaily.co.uk/tv/im-a-celebrity-fans-question-why-frankie-got-a-camera-as-her-luxury-item/">
                                    I&#8217;m A Celebrity fans question why Frankie got a camera as her luxury item                                </a>
                            </div>
                        </div>

                    
                        <div class="mt-2 w-1/2 sm:w-1/3">
                            <div class="ml-3">
                                                                    <div class="force-aspect mb-px">
                                        <a href="https://www.entertainmentdaily.co.uk/tv/strictly-tony-adams-katya-jones-furious-row/" tabindex="-1">
                                            <img class="w-full absolute inset-0 lazyload" alt="Tony and Katya" sizes="(min-width: 1150px) 240px, (min-width: 640px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/06105202/tony-k-fi-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/06105202/tony-k-fi-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2022/11/06105202/tony-k-fi-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/06105202/tony-k-fi-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2022/11/06105202/tony-k-fi-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2022/11/06105202/tony-k-fi-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/06105202/tony-k-fi-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/06105202/tony-k-fi.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/06105202/tony-k-fi-742x388.jpg" alt="Tony and Katya" class="w-full absolute inset-0 lazyload"></noscript>                                        </a>
                                    </div>
                                                                <a href="https://www.entertainmentdaily.co.uk/tv/strictly-tony-adams-katya-jones-furious-row/">
                                    Strictly: Tony Adams and Katya Jones have furious ‘argument’ during live show                                </a>
                            </div>
                        </div>

                    
                        <div class="mt-2 w-1/2 sm:w-1/3">
                            <div class="ml-3">
                                                                    <div class="force-aspect mb-px">
                                        <a href="https://www.entertainmentdaily.co.uk/tv/strictly-hamza-yassin-blow-controversy/" tabindex="-1">
                                            <img class="w-full absolute inset-0 lazyload" alt="Strictly star Hamza dancing with Jowita" sizes="(min-width: 1150px) 240px, (min-width: 640px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/06095727/Hamza-dancing-742x388.png" data-srcset="https://cdn.entertainmentdaily.com/2022/11/06095727/Hamza-dancing-742x388.png 742w, https://cdn.entertainmentdaily.com/2022/11/06095727/Hamza-dancing-768x401.png 768w, https://cdn.entertainmentdaily.com/2022/11/06095727/Hamza-dancing-360x188.png 360w, https://cdn.entertainmentdaily.com/2022/11/06095727/Hamza-dancing-180x94.png 180w, https://cdn.entertainmentdaily.com/2022/11/06095727/Hamza-dancing-800x418.png 800w, https://cdn.entertainmentdaily.com/2022/11/06095727/Hamza-dancing-400x209.png 400w, https://cdn.entertainmentdaily.com/2022/11/06095727/Hamza-dancing.png 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/06095727/Hamza-dancing-742x388.png" alt="Strictly star Hamza dancing with Jowita" class="w-full absolute inset-0 lazyload"></noscript>                                        </a>
                                    </div>
                                                                <a href="https://www.entertainmentdaily.co.uk/tv/strictly-hamza-yassin-blow-controversy/">
                                    Strictly: Hamza Yassin delivered blow as he finds himself at centre of fresh controversy                                </a>
                            </div>
                        </div>

                                        </div>
                </div>
                
            </div>

            <aside class="flex-sidebar js-sidebar">
		                            <div class="my-6 py-2 bg-gray-200 border-t-2 border-brand text-sm leading-tight">
                        <h3 class="px-3 uppercase italic text-sm">More TV</h3>
                        <div class="flex flex-wrap text-brand mr-3">
					                                        <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                    <div class="ml-3">
								                                                    <div class="force-aspect mb-px">
                                                <a href="https://www.entertainmentdaily.co.uk/tv/jock-lewes-sas-rogue-heroes-sas-co-founder-what-happened/" tabindex="-1">
											        <img class="w-full absolute inset-0 lazyload" alt="Jock Lewes dressed in army uniform in SAS Rogue Heroes" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/01171048/Jock-Lewes-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/01171048/Jock-Lewes-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2022/11/01171048/Jock-Lewes-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/01171048/Jock-Lewes-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2022/11/01171048/Jock-Lewes-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2022/11/01171048/Jock-Lewes-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/01171048/Jock-Lewes-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/01171048/Jock-Lewes.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/01171048/Jock-Lewes-742x388.jpg" alt="Jock Lewes dressed in army uniform in SAS Rogue Heroes" class="w-full absolute inset-0 lazyload"></noscript>                                                </a>
                                            </div>
								                                                <a href="https://www.entertainmentdaily.co.uk/tv/jock-lewes-sas-rogue-heroes-sas-co-founder-what-happened/">
									        Jock Lewes in SAS Rogue Heroes: Who was the SAS co-founder and what happened to him?                                        </a>
                                    </div>
                                </div>
					                                        <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                    <div class="ml-3">
								                                                    <div class="force-aspect mb-px">
                                                <a href="https://www.entertainmentdaily.co.uk/tv/where-was-sas-rogue-heroes-filmed-locations-set-bbc-drama/" tabindex="-1">
											        <img class="w-full absolute inset-0 lazyload" alt="Connor Swindells posing in the desert" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/03122118/SAS-Rogue-Heroes-2-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/03122118/SAS-Rogue-Heroes-2-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2022/11/03122118/SAS-Rogue-Heroes-2-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/03122118/SAS-Rogue-Heroes-2-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2022/11/03122118/SAS-Rogue-Heroes-2-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2022/11/03122118/SAS-Rogue-Heroes-2-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/03122118/SAS-Rogue-Heroes-2-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/03122118/SAS-Rogue-Heroes-2.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/03122118/SAS-Rogue-Heroes-2-742x388.jpg" alt="Connor Swindells posing in the desert" class="w-full absolute inset-0 lazyload"></noscript>                                                </a>
                                            </div>
								                                                <a href="https://www.entertainmentdaily.co.uk/tv/where-was-sas-rogue-heroes-filmed-locations-set-bbc-drama/">
									        Where was SAS Rogue Heroes filmed? Every filming location in the new BBC drama                                        </a>
                                    </div>
                                </div>
					                                        <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                    <div class="ml-3">
								                                                    <div class="force-aspect mb-px">
                                                <a href="https://www.entertainmentdaily.co.uk/tv/sas-rogue-heroes-soundtrack-songs-bbc-one-drama-theme-music/" tabindex="-1">
											        <img class="w-full absolute inset-0 lazyload" alt="Connor Swindells and Alfie Allen in SAS Rogue Heroes" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/03145337/SAS-Rogue-Heroes-3-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/03145337/SAS-Rogue-Heroes-3-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2022/11/03145337/SAS-Rogue-Heroes-3-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/03145337/SAS-Rogue-Heroes-3-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2022/11/03145337/SAS-Rogue-Heroes-3-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2022/11/03145337/SAS-Rogue-Heroes-3-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/03145337/SAS-Rogue-Heroes-3-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/03145337/SAS-Rogue-Heroes-3.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/03145337/SAS-Rogue-Heroes-3-742x388.jpg" alt="Connor Swindells and Alfie Allen in SAS Rogue Heroes" class="w-full absolute inset-0 lazyload"></noscript>                                                </a>
                                            </div>
								                                                <a href="https://www.entertainmentdaily.co.uk/tv/sas-rogue-heroes-soundtrack-songs-bbc-one-drama-theme-music/">
									        SAS Rogue Heroes soundtrack: All of the songs in the BBC One drama                                        </a>
                                    </div>
                                </div>
					                                        <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                    <div class="ml-3">
								                                                    <div class="force-aspect mb-px">
                                                <a href="https://www.entertainmentdaily.co.uk/tv/strictly-results-viewers-sad-elimination-dancer-cries/" tabindex="-1">
											        <img class="w-full absolute inset-0 lazyload" alt="Strictly couple in the dance off" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-742x388.png" data-srcset="https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-742x388.png 742w, https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-768x401.png 768w, https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-360x188.png 360w, https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-180x94.png 180w, https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-800x418.png 800w, https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-400x209.png 400w, https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit.png 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/06170605/Strictly-exit-742x388.png" alt="Strictly couple in the dance off" class="w-full absolute inset-0 lazyload"></noscript>                                                </a>
                                            </div>
								                                                <a href="https://www.entertainmentdaily.co.uk/tv/strictly-results-viewers-sad-elimination-dancer-cries/">
									        Strictly results: Viewers reveal their &#8216;sadness&#8217; over elimination as &#8216;disappointed&#8217; pro dancer shares his upset                                        </a>
                                    </div>
                                </div>
					                                        <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                    <div class="ml-3">
								                                                    <div class="force-aspect mb-px">
                                                <a href="https://www.entertainmentdaily.co.uk/tv/im-a-celebrity-matt-hancock-main-motivation-revealed/" tabindex="-1">
											        <img class="w-full absolute inset-0 lazyload" alt="Matt Hancock and his I&#039;m A Celebrity co-stars" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-742x388.png" data-srcset="https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-742x388.png 742w, https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-768x401.png 768w, https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-360x188.png 360w, https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-180x94.png 180w, https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-800x418.png 800w, https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-400x209.png 400w, https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1.png 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/06160536/Matt-Hancock-1-742x388.png" alt="Matt Hancock and his I&#039;m A Celebrity co-stars" class="w-full absolute inset-0 lazyload"></noscript>                                                </a>
                                            </div>
								                                                <a href="https://www.entertainmentdaily.co.uk/tv/im-a-celebrity-matt-hancock-main-motivation-revealed/">
									        I&#8217;m A Celebrity: Matt Hancock&#8217;s &#8216;main motivation&#8217; for taking part &#8216;revealed&#8217;                                        </a>
                                    </div>
                                </div>
					                                        <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                    <div class="ml-3">
								                                                    <div class="force-aspect mb-px">
                                                <a href="https://www.entertainmentdaily.co.uk/tv/strictly-shirley-ballas-time-off-trolling-blunder/" tabindex="-1">
											        <img class="w-full absolute inset-0 lazyload" alt="Shirley Ballas pointing and Dianne Buswell inset" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/06141132/shirley-d-fi-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/06141132/shirley-d-fi-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2022/11/06141132/shirley-d-fi-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/06141132/shirley-d-fi-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2022/11/06141132/shirley-d-fi-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2022/11/06141132/shirley-d-fi-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/06141132/shirley-d-fi-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/06141132/shirley-d-fi.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/06141132/shirley-d-fi-742x388.jpg" alt="Shirley Ballas pointing and Dianne Buswell inset" class="w-full absolute inset-0 lazyload"></noscript>                                                </a>
                                            </div>
								                                                <a href="https://www.entertainmentdaily.co.uk/tv/strictly-shirley-ballas-time-off-trolling-blunder/">
									        Strictly: Shirley Ballas ‘books three weeks off’ to deal with impact of trolling as fans blast ‘rude’ blunder                                        </a>
                                    </div>
                                </div>
					                                </div>
                    </div>
		        
                <div class="my-6 py-2 bg-gray-200 border-t-2 border-brand text-sm leading-tight">
                    <h3 class="px-3 uppercase italic text-sm">Latest News</h3>
                    <div class="flex flex-wrap text-brand mr-3">
				        
                            <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                <div class="ml-3">
							                                                <div class="force-aspect mb-px">
                                            <a href="https://www.entertainmentdaily.co.uk/tv/miles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown/" tabindex="-1">
										        <img class="w-full absolute inset-0 lazyload" alt="Miles Jupp smiling on the red carpet and wearing army uniform in SAS Rogue Heroes" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/02153107/Miles-Jupp-742x388.jpg" alt="Miles Jupp smiling on the red carpet and wearing army uniform in SAS Rogue Heroes" class="w-full absolute inset-0 lazyload"></noscript>                                            </a>
                                        </div>
							                                            <a href="https://www.entertainmentdaily.co.uk/tv/miles-jupp-sas-rogue-heroes-maj-knox-actor-net-worth-wife-trigger-point-crown/">
								        Miles Jupp in SAS Rogue Heroes: Who is the Maj Knox actor and what is he famous for?                                    </a>
                                </div>
                            </div>

				        
                            <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                <div class="ml-3">
							                                                <div class="force-aspect mb-px">
                                            <a href="https://www.entertainmentdaily.co.uk/news/duran-duran-andy-taylor-incurable-cancer/" tabindex="-1">
										        <img class="w-full absolute inset-0 lazyload" alt="Duran Duran at Fashion Rocks in 2005" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/06183522/Duran-Duran-742x388.png" data-srcset="https://cdn.entertainmentdaily.com/2022/11/06183522/Duran-Duran-742x388.png 742w, https://cdn.entertainmentdaily.com/2022/11/06183522/Duran-Duran-768x401.png 768w, https://cdn.entertainmentdaily.com/2022/11/06183522/Duran-Duran-360x188.png 360w, https://cdn.entertainmentdaily.com/2022/11/06183522/Duran-Duran-180x94.png 180w, https://cdn.entertainmentdaily.com/2022/11/06183522/Duran-Duran-800x418.png 800w, https://cdn.entertainmentdaily.com/2022/11/06183522/Duran-Duran-400x209.png 400w, https://cdn.entertainmentdaily.com/2022/11/06183522/Duran-Duran.png 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/06183522/Duran-Duran-742x388.png" alt="Duran Duran at Fashion Rocks in 2005" class="w-full absolute inset-0 lazyload"></noscript>                                            </a>
                                        </div>
							                                            <a href="https://www.entertainmentdaily.co.uk/news/duran-duran-andy-taylor-incurable-cancer/">
								        Duran Duran star Andy Taylor admits there’s ‘no cure’ as he reveals stage 4 cancer diagnosis                                    </a>
                                </div>
                            </div>

				        
                            <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                <div class="ml-3">
							                                                <div class="force-aspect mb-px">
                                            <a href="https://www.entertainmentdaily.co.uk/soaps/emmerdale-spoilers-natalie-ann-jamieson-new-serial-killer/" tabindex="-1">
										        <img class="w-full absolute inset-0 lazyload" alt="Emmerdale logo with grim reaper" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/06112141/emmerdale-serial-killer-itv-comp-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/06112141/emmerdale-serial-killer-itv-comp-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2022/11/06112141/emmerdale-serial-killer-itv-comp-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/06112141/emmerdale-serial-killer-itv-comp-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2022/11/06112141/emmerdale-serial-killer-itv-comp-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2022/11/06112141/emmerdale-serial-killer-itv-comp-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/06112141/emmerdale-serial-killer-itv-comp-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/06112141/emmerdale-serial-killer-itv-comp.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/06112141/emmerdale-serial-killer-itv-comp-742x388.jpg" alt="Emmerdale logo with grim reaper" class="w-full absolute inset-0 lazyload"></noscript>                                            </a>
                                        </div>
							                                            <a href="https://www.entertainmentdaily.co.uk/soaps/emmerdale-spoilers-natalie-ann-jamieson-new-serial-killer/">
								        Emmerdale spoilers: Natalie Ann Jamieson hints there is a new serial killer in the village                                    </a>
                                </div>
                            </div>

				        
                            <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                <div class="ml-3">
							                                                <div class="force-aspect mb-px">
                                            <a href="https://www.entertainmentdaily.co.uk/royals/princess-kate-meghan-markle-podcast/" tabindex="-1">
										        <img class="w-full absolute inset-0 lazyload" alt="Meghan Markle and Kate Middleton smiling" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/06153844/meghan-markle-kate-middleton-comp-splash-742x388.jpg" data-srcset="https://cdn.entertainmentdaily.com/2022/11/06153844/meghan-markle-kate-middleton-comp-splash-742x388.jpg 742w, https://cdn.entertainmentdaily.com/2022/11/06153844/meghan-markle-kate-middleton-comp-splash-768x401.jpg 768w, https://cdn.entertainmentdaily.com/2022/11/06153844/meghan-markle-kate-middleton-comp-splash-360x188.jpg 360w, https://cdn.entertainmentdaily.com/2022/11/06153844/meghan-markle-kate-middleton-comp-splash-180x94.jpg 180w, https://cdn.entertainmentdaily.com/2022/11/06153844/meghan-markle-kate-middleton-comp-splash-800x418.jpg 800w, https://cdn.entertainmentdaily.com/2022/11/06153844/meghan-markle-kate-middleton-comp-splash-400x209.jpg 400w, https://cdn.entertainmentdaily.com/2022/11/06153844/meghan-markle-kate-middleton-comp-splash.jpg 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/06153844/meghan-markle-kate-middleton-comp-splash-742x388.jpg" alt="Meghan Markle and Kate Middleton smiling" class="w-full absolute inset-0 lazyload"></noscript>                                            </a>
                                        </div>
							                                            <a href="https://www.entertainmentdaily.co.uk/royals/princess-kate-meghan-markle-podcast/">
								        Princess Kate to appear on Meghan Markle&#8217;s podcast after &#8216;generous&#8217; offer from Duchess of Sussex?                                    </a>
                                </div>
                            </div>

				        
                            <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                <div class="ml-3">
							                                                <div class="force-aspect mb-px">
                                            <a href="https://www.entertainmentdaily.co.uk/royals/extra-bank-holiday-king-charles-coronation-rishi-sunak/" tabindex="-1">
										        <img class="w-full absolute inset-0 lazyload" alt="King Charles and Rishi Sunak" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/06152813/Rishi-Charles-742x388.png" data-srcset="https://cdn.entertainmentdaily.com/2022/11/06152813/Rishi-Charles-742x388.png 742w, https://cdn.entertainmentdaily.com/2022/11/06152813/Rishi-Charles-768x401.png 768w, https://cdn.entertainmentdaily.com/2022/11/06152813/Rishi-Charles-360x188.png 360w, https://cdn.entertainmentdaily.com/2022/11/06152813/Rishi-Charles-180x94.png 180w, https://cdn.entertainmentdaily.com/2022/11/06152813/Rishi-Charles-800x418.png 800w, https://cdn.entertainmentdaily.com/2022/11/06152813/Rishi-Charles-400x209.png 400w, https://cdn.entertainmentdaily.com/2022/11/06152813/Rishi-Charles.png 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/06152813/Rishi-Charles-742x388.png" alt="King Charles and Rishi Sunak" class="w-full absolute inset-0 lazyload"></noscript>                                            </a>
                                        </div>
							                                            <a href="https://www.entertainmentdaily.co.uk/royals/extra-bank-holiday-king-charles-coronation-rishi-sunak/">
								        Extra bank holiday: Rishi Sunak makes final decision over day off for King Charles&#8217; coronation                                    </a>
                                </div>
                            </div>

				        
                            <div class="mt-2 w-1/2 sm:w-1/3 lg:w-auto">
                                <div class="ml-3">
							                                                <div class="force-aspect mb-px">
                                            <a href="https://www.entertainmentdaily.co.uk/tv/strictly-giovanni-pernice-shock-sex-life-boast/" tabindex="-1">
										        <img class="w-full absolute inset-0 lazyload" alt="Strictly star Giovanni with his top off and smiling" sizes="(min-width: 1024px) 276px, (min-width: 500px) 200px, 49vw" data-src="https://cdn.entertainmentdaily.com/2022/11/06144946/Giovanni-Strictly-742x388.png" data-srcset="https://cdn.entertainmentdaily.com/2022/11/06144946/Giovanni-Strictly-742x388.png 742w, https://cdn.entertainmentdaily.com/2022/11/06144946/Giovanni-Strictly-768x401.png 768w, https://cdn.entertainmentdaily.com/2022/11/06144946/Giovanni-Strictly-360x188.png 360w, https://cdn.entertainmentdaily.com/2022/11/06144946/Giovanni-Strictly-180x94.png 180w, https://cdn.entertainmentdaily.com/2022/11/06144946/Giovanni-Strictly-800x418.png 800w, https://cdn.entertainmentdaily.com/2022/11/06144946/Giovanni-Strictly-400x209.png 400w, https://cdn.entertainmentdaily.com/2022/11/06144946/Giovanni-Strictly.png 1500w"><noscript><img src="https://cdn.entertainmentdaily.com/2022/11/06144946/Giovanni-Strictly-742x388.png" alt="Strictly star Giovanni with his top off and smiling" class="w-full absolute inset-0 lazyload"></noscript>                                            </a>
                                        </div>
							                                            <a href="https://www.entertainmentdaily.co.uk/tv/strictly-giovanni-pernice-shock-sex-life-boast/">
								        Strictly: Giovanni Pernice&#8217;s shock sex life boast that&#8217;ll make your jaw drop!                                    </a>
                                </div>
                            </div>

				                            </div>
                </div>
            </aside>

        </div>

    </main>

    </div>

    <footer class="bg-brand-dark text-white border-t-8 border-brand mt-2 px-2 py-12">
        <div class="container">

            <div class="flex">
                <div class="sm:flex-1">
                    <a href="/" aria-label="Home">
                        <svg class="w-24 h-16 inline-block fill-current"><use xlink:href="#icon-logo"></use></svg>
                    </a>
                </div>
                <div class="flex-1 inline-block text-white ">
                    <form action="https://www.entertainmentdaily.co.uk/" class="mt-4 ml-4 relative">
                        <input type="text" name="s" class="text-white border-opacity-75 placeholder-opacity-75 lg:text-lg font-sans border-2 p-2 border-white bg-transparent w-full placeholder-white appearance-none" placeholder="Search Entertainment Daily" aria-label="Search">
                        <button class="absolute right-0 inset-y-0" type="submit" aria-label="Search">
                            <svg class="w-6 h-6 lg:m-0 lg:w-8 lg:h-8 opacity-75 fill-current"><use xlink:href="#icon-search"></use></svg>
                        </button>
                    </form>
                </div>
            </div>

            <div class="my-12 py-2 hidden md:block">
                <ul class="uppercase font-medium italic text-center flex justify-between">
                <li><a href="https://www.entertainmentdaily.co.uk/news/" class="hover:underline">News </a></li><li class="group"><a href="https://www.entertainmentdaily.co.uk/tv/" class="hover:underline ">TV </a><ul class="normal-case text-xs"><li><a href="https://www.entertainmentdaily.co.uk/tv-spoilers/" class="hover:underline">TV Spoilers </a></li><li><a href="https://www.entertainmentdaily.co.uk/good-morning-britain/" class="hover:underline">Good Morning Britain </a></li><li><a href="https://www.entertainmentdaily.co.uk/loose-women/" class="hover:underline">Loose Women </a></li><li><a href="https://www.entertainmentdaily.co.uk/the-chase/" class="hover:underline">The Chase </a></li><li><a href="https://www.entertainmentdaily.co.uk/this-morning/" class="hover:underline">This Morning </a></li><li><a href="https://www.entertainmentdaily.co.uk/saturday-night-takeaway/" class="hover:underline">Saturday Night Takeaway </a></li><li><a href="https://www.entertainmentdaily.co.uk/netflix/" class="hover:underline">Netflix </a></li></ul></li><li class="group"><a href="https://www.entertainmentdaily.co.uk/soaps/" class="hover:underline">Soaps </a><ul class="normal-case text-xs"><li><a href="https://www.entertainmentdaily.co.uk/eastenders/" class="hover:underline">EastEnders </a></li><li><a href="https://www.entertainmentdaily.co.uk/coronation-street/" class="hover:underline">Coronation Street </a></li><li><a href="https://www.entertainmentdaily.co.uk/emmerdale/" class="hover:underline">Emmerdale </a></li></ul></li><li><a href="https://www.entertainmentdaily.co.uk/royals/" class="hover:underline">Royals </a></li><li><a href="https://www.entertainmentdaily.co.uk/true-crime/" class="hover:underline">True Crime </a></li>                </ul>
            </div>

            <div class="my-6 text-sm text-center uppercase">
                <a href="https://www.facebook.com/entertainmentdailyfix/" class="mx-3">
                    <svg class="w-8 h-8 inline fill-current my-3"><use xlink:href="#icon-facebook"></use></svg>
                </a>
                <div>
                    Connect with us
                </div>
            </div>

            <ul class="flex flex-col sm:flex-row font-bold text-center justify-around">
                <li class="group"><a href="https://www.entertainmentdaily.co.uk/about/" class="hover:underline">About Us </a><ul class=""><li><a href="https://www.entertainmentdaily.co.uk/news/meet-the-entertainment-daily-team/" class="hover:underline">Meet The Team </a></li><li><a href="https://www.entertainmentdaily.co.uk/news/entertainment-daily-editorial-policies/" class="hover:underline">Editorial Policies </a></li><li><a href="mailto:hello@entertainmentdaily.co.uk" class="hover:underline">Contact Us </a></li></ul></li><li><a href="https://www.entertainmentdaily.co.uk/cookies/" class="hover:underline js-show-cmp">Cookies Policy </a></li><li><a href="#" class="hover:underline js-show-cmp">Consent Settings </a></li><li><a href="https://www.entertainmentdaily.co.uk/privacy/" class="hover:underline">Privacy </a></li>            </ul>

            <div class="mt-6 text-xs text-center text-opacity-75">
                © 2022 <a href="/" class="underline">www.entertainmentdaily.co.uk</a>. All rights reserved.<br>
                Operated by Digitalbox Publishing Ltd.<br>
                Digitalbox Publishing Ltd. Co Reg No. 09909897
            </div>

        </div>
        <div id="ad-premium"></div>
    </footer>
</div>

<script src="https://dabds.digitalbox.workers.dev/lib.js" data-plop="bfd085cd-e95e-49d7-a0b9-e8bfe9c5f806" async></script>

</body>
</html>
